InterWorx-CP 2.1.3 Released - Critical security fix

InterWorx-CP installs the webmail Horde/IMP webmail application.

The Horde Team has released a critical security fix for the Horde Application Framework versions 3.0 and above.
More information here:

* This InterWorx-CP release fixes the problem by upgrading the Horde Application Framework to the latest version 3.1.1.

This update will be applied automatically within 24 hours if your server has auto-updates enabled (the default). If you choose to perform the update manually, we recommend logging into your server as root, and running the command:

yum update

We’ve included a small group of other bug fixes as well in this release, which are detailed below.

  • webalizer segfault (thanks Neil McMonagle for tracking this one down)
  • Stats.pex fails on cluster manager with no nodes
  • Horde login fails on Cluster setup
  • Horde SAM/TURBA/other modules fail on Cluster setup
  • Uncluster removes FTP accounts
  • Intermittent permissions error when setting autoresponder
  • Unix username generation fails with more than 10 accounts with the same first 8 characters ih the domain
  • Saved transfer log files rotated incorrectly
  • Quota being hit at 90% of usage instead of 100%
  • phpBB ScriptWorx install fails on MySQL version 3.x
  • backup management page in Nodeworx/Siteworx fails with backups larger than 2GB
  • /home/interworx/var/lib/mysql permissions problem
  • IP management page fails to recognize some internal IPs as internal


Hello Paul,

Update ran on box, now Horde is playing up, the layout is completely messed up. See attached.

Any ideas?


My guess would be possibly the old stylesheet being cached? Have you tried restarting your browser, or tried a different browser?



Thanks for this bugs fixe release.


  • Quota being hit at 90% of usage instead of 100%

It’s not solve for accounts of a reseller account.

We have a reseler that have few account s whom hits the 90% of disk storage allow. They are unable to download new files by FTP. They have the messages bout “quota”


Hi Pascal-

The change only affects new SiteWorx accounts that are created. In order to fix the existing accounts, you’ll have to use setquota on each account to set the soft quota equal to the hard quota.


Ok thank you Dustin.

So basicly it measn that before the update the soft quota was set at 10% less than the hard one ?


If the reseler set the storage space to unlimited for this account, validate, then edit this again and set the storage space to the desired limit, it should recreate the quota with soft and hard limit at the same number ?


Yes, that should do the trick Pascal.


Not sure this is related to the recent upgrade, but I’ve been getting these errors on a Cron job just this week (daily – runs once) –


Can’t locate Crypt/ in @INC (@INC contains: /home/supportb/ /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at /etc/cron.daily/auto_cron.cgi line 7.
BEGIN failed–compilation aborted at /etc/cron.daily/auto_cron.cgi line 7.

I suppose the error is telling me it can’t find that particular Perl module - yet, I’ve haven’t monkeyed with Perl, or that site (or this box for that matter) in months.

Do you think the latest point release may have touched anything to do with the Perl installs?


Hi JB,

No, this InterWorx release didn’t change anything with perl. The only changes were to files under /home/interworx/


Thanks for the reply.

I’ll go digging.