InterWorx has already been activated on this box. Quitting

Hello. I?ve been using Interworx for years now, I joined this forum in 2005, and when I have to change my ISP always choose one based on if they offer an Iworx CP more than based on other considerations. I have been with this ISP for years now and for some reason in one of the servers I contracted with them the license expired and they gave a new license number, however, since the license expired I cannot login to Iworx to change the license number. My ISP has given me two different command lines, which supposedly would do the trick and change the license number, both of them have to do with “goiworx.pex”, but I am not sure if I should post them here, none of them worked and I receive the same error message:

[ERROR] InterWorx has already been activated on this box. Quitting...
[ERROR] Activation Failed

So now I have been locked out of Interworx for more than two weeks, my ISP will not help and I have not bought a 500+ license to ask for support directly (Which I used to do back in 2005 and it was great, but I understand it would not be feasible now).
Can anyone help me solve this ???
Thank you and Happy holidays.

Hi justme

Welcome to IW

I am sorry to read your post

If it?s just the license key that needs changing, then you could do that from ssh and vi ~iworx/iworx.ini I think it is from memory then run license.pex or wait for next license run

A good point is all services should continue as normal such as hosting email etc…

In this instance, if you want to open a support ticket with IW and let refer them to this thread and I?m sure IW would help

If you want to post the commands as I suspect it is just license change and license sync commands

Many thanks

John

Thank you John.
Yes, I just need to change the license number, so simple, isn’t it? Well, I have been trying to do it for three weeks now, with the “help” of my ISP. Moreover, I thought it was so simple that it did not deserve a ticket, but at the end, if I have to open one, I will.
I have run these commands:
1.

/home/interworx/bin/goiworx.pex
 /home/interworx/bin/goiworx.pex --key=LICENSE_KEY --email=EMAIL --password=PASSWORD --ignorechecks

Obviously, replacing where appropriate my email, password and new license number. Both of them lead to the same error response posted above. The second one was sent to me after the first clearly did not work.

As you said, fortunately everything seems to be working normally, until it wont? :frowning:

Hi justme

Many thanks

Just a quick thought, but could you ssh into server and run as root or sudo service iworx restart

Then run your last posted command (but make sure licence key is exactly as your provider provided) as root or sudo

Does that still error

The license key is listed in iworx.ini and could be changed then run license sync I believe. But if changing please remember to run service iworx restart first before running licence pex

The services should just continue but no nodeworx/siteworx access until licensed.

Many thanks

John

Hi justme

Sorry I also meant to state only your isp and IW would have access to check license code and check IP address licensed to the licence key.

However, on our billing integration we show the IP address licensed to the license key

Can you log into your control panel with isp and confirm the license key and IP address

Many thanks

John

Thank you. I run as root…

service iworx restart

Service restarted normally, then…

/home/interworx/bin/goiworx.pex --key=LICENSE_KEY --email=EMAIL --password=PASSWORD --ignorechecks

Replacing with the appropiate values and rechecking the license key sent to me by my ISP.
Response:

[ERROR] InterWorx has already been activated on this box. Quitting...
[ERROR] Activation Failed

My ISP does not provide, as far as I know, anywhwere inside their control panel where I can re check the key, they sent that key to me through email. I guess I am going to have to open that ticket after all… I greatly appreciate your help; it is really nice to have someone interested?

Hi Justme

Many thanks

Just for fulness (and maybe quickness as it is new years eve tommorow) could you do the following:

SSH into server

cd ~iworx

vi iworx.ini

locate the following section

[iworx.license]

key=“LICENCE-KEY”

replace LICENCE-KEY with new licence provided and make sure you do not delete " "

save

run as root or sudo service iworx restart

run as root or sudo /home/interworx/cron/license.pex

Does this allow IW-CP

Also below, is the full commands advised prior to opening a ticket (if opening an IW ticket, please post this thread and let IW know I asked you to open a ticket in your IW ticket)

Many thanks

John

The license currently installed on this server is showing up as invalid to InterWorx Control Panel. This may be nothing more than a simple misconfiguration on your system, or the license could actually be invalid. Before opening a support ticket please try the following:

1.Check your system time and verify that it is correct. Even if it is off by only a few minutes you should reset it to the correct time. The easiest way to do so is to run the following in a root shell: service ntpd stop
ntpdate ntp.interworx.com
service ntpd start

2.Make sure your firewall has port 2443 open both outbound and inbound. If it’s not open then InterWorx Control Panel can’t talk to the licensing server.

3.Run the following command from a root shell to re-sync your license after checking the system time: /home/interworx/cron/license.pex

4.After performing the above please refresh [the license error] page to see if the license is now valid.

5.Finally, if the license is still showing as invalid please open a support ticket with the company sold you your license. If you bought your license directly through the InterWorx website then please open a ticket with the InterWorx team directly.

You are a genius, it is working, I knew it was not a thing so hard to do. Thank you very much.

Hi justme

Glad it?s now working

Hope your running latest RC IW 6.4.1. If not, it?s definitely worth updating

Happy new year

John

Hi John, yes, its running InterWorx-CP v6.4.1.
Happy new year for you too, you’ve been very helpful.

Were you able to get this fixed?

vi ~iworx/iworx.ini

find

[iworx.license]

file="/home/interworx/.license"

key="INTERWORX_XXSXXSXXXXXXX"

message_file="/home/interworx/.license-message"

upgrade-link="http://www.interworx.com/buy-now/"

Make sure the key=“INTERWORX_XXSXXSXXXXXXX” Matches the license key you were given

Then run

~iworx/cron/license.pex --sync

That should fix any license issues

Also check your firewall and make sure that you have not blocked 207.32.181.150. Its the IP of the Interworx licensing server and by default it is white listed but it does not hurt to check.

Good Luck!

Hi Tim

yes Justme changed licence after following same details but without the checking the licence IP in firewall (that’s good to know but guess I’ll forget it when needed sorry)

Justme issue was the licence command did not appear to work as expected and change the licence key

We do not use --sync at end of licence pex, is there any reason for using --sync as it appears to resync alright

Many thanks

John

Hey John,

The license IP is automatically white listed in the firewall settings unless you change it.

As for ~iworx/cron/license.pex --sync

That’s just the command that I was taught way back when by Chris, Paul, or Socheat (not really sure who). No idea if the –sync is still necessary. If running the command without not worked then I guess not. What the command does is verify the license with the server manually. Another potential probe would be if the time is off on your server.

yeah i am happy too after the upgrade