Ioncube loader not available to sites

I am trying to get ioncube loader working and wonder if any one has any suggestions.
I have a centos 7 with php 7.1,
I installed ioncube loader.with the interworx improved script
when I run php -v from command line it says its loaded
when i view the info.php inside of the interworx panel it says it’s loaded.
but when i run the php info file on the sites it is not loaded.
Is there another configuration file just for the sites or something I can’t find?
I have installed it on other servers with out issue, but I have tried everything I know.
any help greatly appreciated

Hi vinezero

Welcome to IW

There is a good thread re php multi which shows how to load php modules by yum

You just need to restart php fpm but you can do this from nodeworx, system, webserver restart all fpm php instanced

The post is a stick in the mods section

Many thanks



Please see this thread and read it all

Many thanks


Setup and use MultiPHP, including ioncube

Hi d2d4j, thanks for the reply, I had gone through that thread and wasn’t able to get it to work but
I have it working now I had to set it to use the thread safe version, not sure really why but it is working now.
Better lucky than smart i guess

Did you get any proper solution?

No I didn’t, I tried to manually add it to just that site, it worked for a while but quit working, I think when interworx preformed an update.

Hi Vinezero

I am sorry to hear that… if Ioncube is installed and loaded (as shown by php) then it is unlikely to be anything inside interworx

I would open a support ticket and let IW have a look to see what’s happening

Did you run the ioncube installer for all php versions you have installed and set the website to use the php version ioncube is inatlled on

Many thanks