ipv6 working from ssh (centos 6.6), not in Interworx / Create ipv6 pools


If I check my assigned ipv6 ip address from my provider, I find in Interworx: 2a00:e20:121:400:42e:d8ff:fe00:14b9/64.

Through SSH I can ping to ipv6.google.com, receiving ipv6 answers.

If I check ipv6 status, I get:
ipv6 gateway: Not configured
capable: Yes
initialize set: Yes
Clustering: Yes
Enabled: Yes
ipv6 network routes: All Unreachable.

I assume that is because the gateway is not setup, because ipv6 ping through ssh works, output:
PING ipv6.google.com(ea-in-x64.1e100.net) 56 data bytes
64 bytes from ea-in-x64.1e100.net: icmp_seq=1 ttl=54 time=5.21 ms
64 bytes from ea-in-x64.1e100.net: icmp_seq=2 ttl=54 time=5.18 ms

As I have no experience with ipv6, 2 questions:


  • How to setup the gateway in Interworx, allowing ipv6 traffic. From the ? I understand that I need to edit the IPV6_DEFAULTGW in the primary network controller config, however, as I can ping ipv6 addresses, this should be good, or not?
  • How to setup a small ipv6 pool from 2a00:e20:121:400:42e:d8ff:fe00:14b9/64, which I can use for a customer? [/LIST]

    Kind regards,
    Raymond Jansen

  • Hi Raymond

    I’m sorry, we have yet to start using ipv6, although our datacentre will give a full block to our company.

    I believe you have to set the ipv6 gateway as you stated, and will have to manually edit through ssh. The gateway address should have been supplied by your provider.

    I do know the gateway staus screen your referring to may not correctly show green, which IW were looking into, but I’m not sure if it has been resolved fully or not, but this should not stop ipv6 working if setup correctly. It is just a status screen.

    If your pinging from ssh, it maybe traversing ipv4/ipv6 and might be a red herring.

    In your DNS, do you have any ipv6 addresses for any siteworx accounts shown

    I would check your ipv6 range against the details supplied from your supplier for ipv6, to make sure they match, and are not picked up on dhcp (we suffered this when upstream turned on ipv6, and our systems were assigned wrongly ipv6 ranges)

    If you goto nodeworx, server settings, IP address, ipv6, you should be easily able to set your ipv6 ranges into usable/trackable blocks

    I hope that helps and sorry if I am wrong

    Many thanks


    Hi John,

    I have opened a ticket at my provider, asking for details of ipv6. The address mentioned was automatically detected during install through dhcp.

    I have not yet setup dns for any account to use ipv6. I will wait for the reply of my provider for this.

    Thanks for your help so far. I will get back to this if I have an answer from my provider.

    Kind regards,


    As it turns out my first info was not entirely accurate.

    The provider gives 1 ipv6 address: 2a00:e20:121:400:42e:d8ff:fe00:14b9. This is assigned through dhcp.

    In InterWorx it showes as 2a00:e20:121:400:42e:d8ff:fe00:14b9/64.

    The gateway is supplied through RA (route availability). Manually adding the route in the network card properties does not work. InterWorx ipv6 status shows ipv6 gateway configured, but all ipv6 pings fail in InterWorx.

    Still, in SSH I can ping6 to ipv6.google.com fine.

    Any help?

    Kind regards,

    Hi Raymond

    Many thanks,

    What is shown in your network logs

    Do you use networkmanager

    Is this a vps

    Can you complete a trace route to see where it is failing

    I hope that helps

    Many thanks


    Hi John,

    I can’t find the network logs in Interworx, Nodeworx, Server, Logs.

    I don’t use a network manager.

    The server is a vps.

    In Interworx I can’t find anywhere to do a traceroute. If I do a traceroute in SSH to ipv6.google.com, the output is:
    [root@hosting ~]# traceroute ipv6.google.com
    traceroute to ipv6.google.com (2a00:1450:4013:c00::8a), 30 hops max, 80 byte packets
    1 2a00:f10:121:400::2 (2a00:f10:121:400::2) 0.573 ms 0.598 ms 0.699 ms
    2 2a00:f10:170:352::1 (2a00:f10:170:352::1) 0.388 ms 0.275 ms 0.242 ms
    3 2a00:f10:170:332::1 (2a00:f10:170:332::1) 0.936 ms 0.831 ms 0.866 ms
    4 2a02:27f0:2:304::1 (2a02:27f0:2:304::1) 0.920 ms 0.870 ms 0.808 ms
    5 core1.ams.net.google.com (2001:7f8:1::a501:5169:2) 1.152 ms 1.132 ms 1.144 ms
    6 2001:4860::1:0:87ab (2001:4860::1:0:87ab) 1.499 ms 2001:4860::1:0:87aa (2001:4860::1:0:87aa) 1.370 ms 1.395 ms
    7 2001:4860::8:0:519f (2001:4860::8:0:519f) 13.384 ms 13.156 ms 13.171 ms
    8 2001:4860::8:0:517a (2001:4860::8:0:517a) 5.263 ms 2001:4860::8:0:519e (2001:4860::8:0:519e) 5.429 ms 11.300 ms
    9 2001:4860::2:0:8652 (2001:4860::2:0:8652) 5.403 ms 2001:4860::2:0:8651 (2001:4860::2:0:8651) 5.359 ms 2001:4860::2:0:8652 (2001:4860::2:0:8652) 5.320 ms
    10 ee-in-x8a.1e100.net (2a00:1450:4013:c00::8a) 5.219 ms 5.177 ms 4.967 ms

    I hope this helped. Will try everything you ask.



    I have submitted a ticket to Interworx. Nathan was kind enough to look into my problem.

    I have given Nathan access to my server. It seems that because the defaultgw for ipv6 is missing from the ifcfg-eth0 is a problem for Interworx. In SSH ipv6 works normally. Nathan is going to ask development if there is a possible workaround.

    If a workaround is not possible, I could switch to a different vps provider where the ipv6 has to be in ifcfg-eth0 and not advertised through RA.

    Thanks John!

    Kind regards,

    Hi Raymond

    Glad IW have looked into it and the issue is now known.

    I’m sorry, as I said, we do not use IPV6 currently, but as I was working away for a few days, I thought it might be gateway as issue, clearly wrong but as I do not access other systems, is hard to know full facts or run tests.

    We had similar when setting up multiple networks on same server, and it was easy to fix using routes, as the system did not know which route to take, on which gateway for the new IP’s (IPV4). Once we had told the system, it worked lovely, which if it helps and you want to try as test, below is what I believe you need to use. I’m sorry if I am wrong. The first part should tell you which nic (device) is used by IPV6, assigned by RA, which you can then use this to set the IP routes with, so the system knows which gateway/route to use.

    The above though, is only my thoughts, which I am sure IW have already tried/thought off, as those guys rock.

    Lastly, as I think if your system is using IPV6 (well setup for IPV6 and IPV6 works in SSH), I would check your email server to make sure it is not using your IPV6 address, if it is, I would either disable it or make sure you have RDNS set on it. Qmail would use IPV6 first if available over IPV4, even if you set the Qmail to use only IPV4.

    To test, send an email from your IW server and look at the header details.

    I hope that helps a little

    Many thanks


    /route -A inet6 - to find all IPV6 routes/device

    route -A inet6 add <ipv6network>/<prefixlength> gw <ipv6address> [dev <device>]

    ip -6 route add <ipv6network>/<prefixlength> dev <device> src <ipv6network> table admin
    ip -6 route add default via <ipv6network-Gateway> dev <device> table admin
    ip -6 rule add from <ipv6network> table admin
    ip -6 rule add to <ipv6network> table admin
    ip -6 route flush cache

    Hi John,

    I have been very busy at work for the last days. Sorry for my late reply!

    I have switched my VPS provider. The new provider lets me manage the ipv6 settings in my ifcfg-eth0 file.

    Then, when I transferred my site, everything worked instantly!

    I use an outgoing spam filter for all my emails. That workes fine with ipv6.

    Thank you very much for your time!

    Kind regards,