Is Interworx compatible with MariaDB v10?

Hi,

I have made a new and fresh installation of Interworx v5.1.14 on a CentOS 7 server and I noticed that is running MariaDB v5 and I want to update MariaDB to the latest v10.1 or at least the v10.

So about this I have 2 questions:

1- Is Interworx is fully compatible with both MariaDB 10 and 10.1 versions?

2- What is the best way to update the current MariaDB v5 to the new version? Is this the best way or are there better ways to do it: http://www.tecmint.com/upgrade-mariadb-5-5-to-10-centos-rhel-debian-ubuntu/

Thanks

Hi nqservices

Welcome to IW forums

IW use their own versions, so you should be good to update as far as I know

If you have a test server, you may be better to try on that first

If mariadb v10/10.1 is similar to latest MySQL community, it may not be fully compatible yet, but this is just a feeling I have

Ofcourse I maybe wrong, so apologies in advance and hopefully another user who use centos 7 and has upgraded may post their experience

Many thanks

John

Hi John,

Thanks for the advice. So you are telling me that in a official way Interworx still not support MariaDB v10. But it can work depending on the setup, correct?

Is there any link on Interworx website where i can see what are the latest PHP, MariaDB and OS that are official supported and 100% compatible?

Also is there any user out there using CentOS 7 + MariaDB 10 or 10.1 with Interworx? Can you share your expericence?

Thanks

Hi Nqservices
Sorry, no I am not quoting officially or unofficially over MariaDB, I do not work for Interworx but was soo impressed with IW, even though we hold full unbranded licences, we have not rebranded as it is an excellent selling point.
Interworx uses MariaDB with centos 7, but I do not currently use Centos 7, either in test servers or production, however, from time to time I will load a Centos 7 test server, time permitting.
Interworx use their own services, so upgrading MariaDB or Mysql should be fine, the versions you install or upgrade are up to you, but as I have not tried MariaDB v10/10.1, I could not honestly say if it would work, sorry.
I do know PHP 7 works, as I have tried this on test servers, but as there are currently no Ioncube loaders or Zend (granted Ioncube have a Beta out now), we do not use PHP 7, but it does work if you do not use ioncube or Zend.
Also, I just checked on 1 of our NS, and that is using Mysql community edition (5.5.5), so my thinking may be wrong, or it may have progressed since I last looked.
I do know a lot of users use Centos 7, so hopefully they will post their experiences
I hope that helps
Many thanks
John

Hi,

Just to inform all community that i’m using CentOS 7 + Interworx and i have update MariaDB to v10:

+++++++++++++++++++++++++++++++++++++++++++++++++
[[email protected] ~]# mysql -V
mysql Ver 15.1 Distrib 10.0.25-MariaDB, for Linux (x86_64) using readline 5.1
+++++++++++++++++++++++++++++++++++++++++++++++++

When i login phpmyadmin it shows the updated MariaDB version and all seems to work properly.

But when i go to Nodeworx > System Services > MySQL Server > Overview, i still see the version 5.5.5. I know that Interworx uses it’s own MySQL so i want to know if this is normal or if here it should show the new MariaDB version v10?

Also one problem i found is that after the MariaDB update the MySQL > “Start on boot up” option is set to “No” and if i try to set to “Yes” it shows the following error:


There was a problem validating the form. Please see details below.
? Changing service start-on-boot failed

Is anyone experience the same problem? Does anyone else here on the forum uses CentOS 7 + MariaDB v10?

Thanks

I just converted to MariaDB v10. All is fine Technically. The only issue is The GUI reads as 5.5.5 version.