Issues importing from Cpanel


I’ve been playing around with several control panels since the Cpanel price increase announcement and thought I had settled on InterWorx. My intent was to only host 6 odd accounts totaling about 100gb of data. All personal sites with little traffic. One of the accounts is about 80gb on its own, consisting primarily of a NextCloud install and email. The NextCloud data directory is below the public_html directory.

I successfully imported the other 5 accounts using the mass import function (bar issue below with DNS). I’ve have tried importing the big account 4 times now using both the mass import and a manual import via CLI - both times it brings across data in the public_html directory only. Email accounts get brought across but email data does not. The NextCloud data directory gets skipped each time as well.

The issues I’m facing are:

  • The email accounts are mdbox format rather than maildir - does Interworx support the importation of mdbox format email boxes from Cpanel?
  • The account import function obviously skips everything that isn’t in the public directory, is there anyway to override this? (I could manually import but I’d rather not)
  • Unable to create a SiteWorx account for the hostname so can’t generate LetsEncrypt SSL via the instructions on this forum. (Get given error that domain already exists)’
  • DNS entires were stripped back to basics on import - one account has around 100 entries with only 15 or so being loaded into InterWorx on import

Are these bugs or limitations in InterWorx? Thought I’d ask here first being seeking support from licencor.

Centos 7.6
6gb ram
200gb Hdd
2 IP’s


Sorry correction, Cpanel install is using maildir not mdbox.

Hi kingjj

Welcome to IW forums

I would consider an 80gb import would fail (most likely times out). I would also think any other control panel which attempted the import would fail for similar reasons.

The import works by creating a backup file of the domain, which is compressed, transfer it to IW server and the reverse the process and change ipv4 and ipv6 (if used) to correct dns for IW server, setting the account type/user etc… but there are limitations such as size.

I would do a partial import (if CPanel allows it) and then upload files

The error domain already exists is correct, as it does exist in the DNS zones.

So if you want to manually setup domain, goto nodeworx, services, dns, zones - locate the domain and delete the zone

Let’s encrypt would only work if the dns records are pointed at the IW server for the ssl you are creating it for. If dns records are pointed somewhere other then the IW server, LE should fail - do not keep trying to generate using LE using live if above is not pointed, you will be locked out by LE for 12 hours I think it is.

I am sorry I do not know nextcloud, and do not know if it would work with IW, so perhaps another IW user could answer or licencecart

Many thanks


Kiaora @d2d4j , thanks for your reply.

Would it show an error (either on the panel, in the cli or in a log somewhere) to show an import has timed out? The last import i ran was via the CLI and it does mention that the archive was extracted sucessfully however it does give the following on the next line:
Did not find homedir.tar /tmp/cpanelImportaT7V5s/cpmove-USER/homedir.tar
Is that an expected message do you know?

I have since migrated the NextCloud install to its own VPS which is probably a better solution anyway so worse case I’ll remove it from the Cpanel version which will make the import only 5gb~.

Thanks for the instructions on adding the hostname to SiteWorx, I will give that a go.

Any thoughts on the mail not getting imported? It’s not just the problem account that didn’t have its mail contents moved, all the accounts imported from Cpanel to InterWorx did not include the mail box contents.

Appreciate your time!

Hi kingjj

Many thanks

I am sorry, I said time out as an example - not that it is the reason

To see why it is failing, including maildir, goto nodeworx, server, logs, interworx, iWorx and error logs

This will show why there failing

Just a thought, but if ssl on import is set to dedicated ip, or you have already set a dedicated ip for a domain and it trying to use that ip, it would fail to import

Also, I do not have access to CPanel or a CPanel backup to test - but 2 weeks ago we imported without issues

Also, if the resources such as storage use is unlimited on on CPanel but you limit it in interworx, it may fail as I believe all have to match each CPanel and interworx

The maildir issue you may be better contacting interworx as they do take CPanel import seriously and where there are issues, do like to review/correct as things are always changing

If you have removed nextcloud, and site is circa 5GB, then I would think it may import without issues

The first I try when importing, is using mass import, click CPanel and use CPanel ssh credentials

Many thanks


HI @kingjj
I am also moving from cPanel to Interworx, please don’t give up, as it is a very good panel, I used cPanel 15+ years, wish I had found this one earlier.

a few things, if I may suggest, please go in cpanel and changed mdbox to maildir, one of the benefits of maildir is the easy to recover the email or just a few as mdbox is one huge file and maildir is many files. cPanel has a script to convert from mdbox to maildir or other-way around…

The import script has had quite a few important updates based on my experience, Interworx is still working on a few other issues I noticed, like the ones you face with folders above public_html.

Although not recommend,but to have latest import script you need to update to Beta version 6.3.19.x, in Nodeworx goto server, server updates and change to Beta channel, save, scroll down, check for updates and apply.

You could also use rsync to copy the Nextcloud folder from cPanel to Interworx account.

Regards DNS entries, you will only be shown the first part, for all others you need to use the other buttons on the top right section for MX SPF and Domain keys, also if you have more than one domain or sub-domains or secondary ones, you have to switch in the top right the domain you are working with, I forgot that most times :slight_smile:

Hope this helps.

Hi John,

Thanks again for your reply. The error logs currently filled with SSL errors (hostname related, unrelated to this issue), I’ll try another import tomorrow and follow the logs as it happens. I have tried the import both with and without a dedicated IP (Cpanel account has dedicated) - both situations have same issue. All imported accounts have hard limits except for some features, I’ve setup corresponding SiteWorx plans for each.

I’ll contact Interworx real the mail issue and see what their thoughts are - thanks for suggestion.

Appreciate your time. Cheers

Kiaora Nico,

Thanks for your reply as well! I was mistaken in my original post, the Cpanel setup is using maildir rather then mdbox, I converted to it earlier this year. I’m not currently using the InterWorx server for anything live so I will try switching to the beta version and trying again (I am happy to rebuild to stable if need be). I’ve decided to move the NextCloud install to its own VPS so I won’t need to import it now to InterWorx (probably for the best, NextCloud is finicky and hard to get working properly on a shared environment).

The DNS one is interesting - the main server domain has a dozen plus subdomains and then another dozen plus A/AAAA records pointing to other servers etc. The subdomains all imported ok as separate entries (as you alluded to) however the A & AAAA records unrelated to subdomains or services on the InterWorx server did not, they had the be recreated manually.

I’ll try upgrading to beta and importing the same problem account and see how it goes! Cheers mate

Hi, yes please, if possible and still in testing do the upgrade to beta and do same import, most of my accounts are not so advanced with dns records as you mentioned, but I would like to hear what is exactly missing for you.
I don’t use the AAAA so can’t check this, but all A records should be there, did you check if there is more than one page? A very fast way to see if all zones are there is in the menu go to System services, DNS server, Zones, it even gives the amount of records, like in cPanel.
Kind regards,

Also while importing from nodework SSH, the interworx imports only files that are in whm cpanel public_html not the files outside public_html, is there any way to import /home/user/* instead of /home/user/public_html/*?


InterWorx imports mail, which is in the user’s home directory, but it only imports specific things, not everything. It seems if you want to import other content from the user’s home directory, you will have to migrate that stuff manually.