Missing Menu for SSL and Let's Encrypt

This is going to seem a silly question but what’s happened to the ssl menu in Siteworx.
im running version 7 of Interworx with the let’s encrypt plugin enabled,
That seems to work at least via CLI and for services, but i can’t find the menu option in Siteworx under any domains.
Has this been moved or am i missing a setting to turn it on?
Thanks
Andrew

Hi ayearp

Welcome to IW forums

Are you a yorkshire man… your tag sounds like a yorkshire saying

If you are a siteworx user only, you would have to ask your provider to add it to your siteworx account

If your a nodeworx user, you need to login to nodeworx, nodeworx, applications, lets encrypt and turn on

Then edit the siteworx accounts and turn on ssl

It will then appear in menu and work

Please remember for LE for SSL, it needs the dns records to point and resolve to the server for the ssl been generated. Any that do not would mean it fails on dns so only highlight those dns records you know are pointing at your server

Many thanks

John

In v7 SSLs and LE are managed from Siteworx > Domains > Manage, click the Shield with the padlock icon. We are not quite happy with how user friendly this is and our UI guy is working on it.

Like @d2d4j said this is presuming SSL has been enabled for the Siteworx account from Nodeworx.

Hi

@ayearp I am so sorry, you have posted the following (tired eyes late at night)

So you are a nodeworx admin/server admin and I do not have IW-CP v7 as yet (no time at moment and please remember I do not work for IW/Liquidweb)

It will be as Iworx-joseph posted or as I posted and you have not added SSl to the siteworx account.

It is easier to create a siteworx template and use that for creating new siteworx accounts but any siteworx accounts not showing SSL as an option, needs to be manually edited from nodeworx siteworx list and turned on

Many thanks

John

Thanks John & Joseph.
This is the strange bit i have checked and both the plugin and the ssl for Siteworx account are enabled.
So is SNI under the general settings.
Yet no menu option but i can create a cert using the command line tools.
Ive attached a screen shot of Siteworx (missing the menu)
Thanks
Andrew

Hi Andrew

Many thanks

It certainly sounds that you have completed all required steps to show/use ssl

Just a couple of points

Was any errors shown during the turn on

Is the assigned IP address to the siteworx account set as dedicated or shared. If dedicated, could you change to shared as a test (thinking perhaps if dedicated it maybe assigned to a different siteworx account)

Can you login using a different browser you have not used to view the siteworx account or use private browser and then login - thinking browser cache is been displayed

If this does not show, I would open a support ticket with IW and also quote your forum thread so IW could have a proper look to see why

They are excellent and keep you informed all the time and hopefully, IW or yourself may post with reason and how to fix

Many thanks

John

Hello–

What version of IW7 are you running?
Is this server using a single domain license?

SSL is no longer its own menu item–it is listed under Manage under Hosting Features > Domains.

However, based on your screenshot, that link seems to be missing for you.

There was a bug recently where, if a SiteWorx account did not have secondary domains enabled, the “Manage” option did not appear in SiteWorx. This was resolved in 7.1.1 for most accounts, however, it was discovered a week or so ago that the issue still affected single domain licenses. That fix is complete, though I do not believe it has been pushed, yet.

I’ll double check with the devs on the status of that fix, but in the meantime, let me know whether you are using a single domain license and/or what the version is (you can see this by either using ‘rpm -q interworx’ at the command line, or at the very bottom of the page in the GUI.

Thanks!
-Jenna
Friendly Neighborhood Support Manager

Hi

Kudos to IW and looks like I need to be installing V7 on a test server

Many thanks

John

HI Jenna
Thanks
Sorry for a slow reply.
It seems like it might have been that bug as after updating to 7.2.0 the menu is now working.
The server is on a 35 domain dedicated license.

Oh good! Glad the update resolved it. :slight_smile: