mod_frontpage installation

From my InterWorx FAQ:

Does InterWorx support the FrontPage server extensions?

Not at this time, but they are planned for a future release. There is NO ETA on this.

In the meantime they may be installed by the end user and will work (with some tweaking). Download them from and follow the directions.

Read the directions completely, but here are the basic steps:

  1. Back up your web data and Apache configuration files [ everything in the /etc/httpd/conf.d directory ]

  2. Download the extensions file (make sure to get the ones for Linux/RedHat)

  3. gunzip the extensions file [gunzip < filename > ]

  4. untar the extensions file [tar -xf < filename > ]

  5. change directories to where you untarred the files [ normally /root/frontpage/frontpage-3.0/ ]

  6. run the script [ ./ ]

  7. Follow the prompts in the script

  8. The install script asks where Perl is installed [ /usr/bin/perl ]

  9. and where the Apache controller is [ /usr/sbin/apachectl ]

10 Create a root web in the directory of the desired site and specify a password.

You’re done!

There are extensions for FP98, FP2000, and FP2002. It is generally best to install the newest, but some people like the older ones because they are (probably) more thoroughly tested and if you don’t use the advanced features then the older ones may be just as good. You can still use newer versions of FrontPage to design your sites because FP extensions are backward compatible, but some of the newer features that require the newer extensions will not work.

If you are looking for a step by step guide check this out. However I have not tested it on an InterWorx server yet, and it uses an older version of apache (1.3.x) so there WILL be several differences.

Good Luck!

NOTE: In the near future I will be installing this on my CentOS server and will document the experience on my InterWorx page.

This assumes you download the source from Ready To Run Software. As stated in another thread Chris has SRPM’s for this in the experemental archive. The procedure is similar, however. I’m going to try to take a look at this tomorrow evening or on Monday if I can find the time.

Hope somebody finds this usefull.

Ok Sago’s Allmanagedserver, tried to install it on my server after I could not, and it still does not work.

From what I understand this is vary low or not even on Interworx’s list of todo’s anymore, so someone that has it working would you be willing to help?

They told me since it is’nt working then interworx will just not support it and they can’t help me any more on ths issue. Waste of a day of down time but anyway.

Some more info, it shows installed, they ran the script or what ever to install it on a test domain, I try to publish and it says the FP extentions are not installed. So I logged in with FTP and there where no FP folders in there like there normally is when FP extentions are installed.

Did you restart httpd? (not reload, restart)

I’m the only one I know who has done this successfully and it was almost a year ago on a different server. I keep meaning to do it on this box but it keeps slipping lower on my list as I do not use FP to design any active sites (at least not sites using FrontPage’s proprietary content).

It’s on InterWorx’s to do list (Chris even put a source RPM on the experemental RPM site) but hasn’t progressed any further on it.


FYI: I am playing with this now. I’ve run into errors and am going to take a fresh stab at it tomorrow.

Server config filename:

I tried the domain conf file (both just the name and the fill path) and the httpd.conf and nothing. when I try:

Server config filename: /etc/hddpd/conf/httpd.conf
./ line 1478: [: too many arguments

then it spits back a whole slew of errors and I have to exit. I remember this from before but don’t recall how I fixed it.


Thanks for looking into this for me, Yes we restarted httpd, I know that much, as for config’s and other things not sure what they tried. :slight_smile:

I’m still working on it and making some progress; will share my notes with you and anyone else who wants them when/if I get it working.


Ok thanks man, I have them working on my home computer right now, which will be fine for awhile I guess.

Anyway I wish you luck :slight_smile:

I could have them running on my home computer too, since it’s Windows; getting it running on Linux is much harder :wink:

Will heep you posted.


When running the install script I get this

Exiting due to an error! Please fix the error and try again.

I tried the script again and got

ln: `/usr/local/frontpage’: File exists
ERROR: Unable to snap link /usr/local/frontpage --> ./y!

Exiting due to an error! Please fix the error and try again.

Tried again and got this:

WARNING: The Apache you are running is newer than the one
supported by this kit.
You are running Apache 2.0.54 .
This kit supports Apache .
Do you wish to continue? (y/n) [N]? y
Using the Apache apxs utility to build
/usr/lib/apr/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -march=i386 -mcpu=i686 -I/usr/kerberos/include -DAP_HAVE_DESIGNATED_INITIALIZER -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE -pthread -I/usr/include/apr-0 -I/usr/include/httpd -Dlinux -c -o /usr/local/frontpage/version5.0/apache2/mod_frontpage.lo /usr/local/frontpage/version5.0/apache2/mod_frontpage.c && touch /usr/local/frontpage/version5.0/apache2/mod_frontpage.slo
mkdir: cannot create directory `/usr/local/frontpage/version5.0/apache2/.libs’: No such file or directory
apxs:Error: Command failed with rc=65536
ERROR: Unable to install mod_frontpage dso

Exiting due to an error! Please fix the error and try again.