Multiple problem (FTP, Iworx License, Softaculous)

Hi Iworx Team’s,

I leased license for one year, I install interworx perfectly but I’ve some bug :

  1. Proftpd problem :

When I wan’t to connect to ftp server with an ftp account I’ve this problem return by my ftp client :

Status: Resolving address of
Status: Connecting to…
Status: Connection established, waiting for welcome message…
Response: 220 FTP Server Ready
Command: USER
Response: 331 Password required for
Command: PASS *******
Response: 230 User logged in
Command: SYST
Response: 215 UNIX Type: L8
Command: FEAT
Response: 211-Features:
Response: MDTM
Response: MFMT
Response: AUTH TLS
Response: MFF modify;;UNIX.mode;
Response: MLST modify*;perm*;size*;type*;unique*;*;UNIX.mode*;UNIX.owner*;
Response: PBSZ
Response: PROT
Response: SIZE
Response: 211 End
Status: Connected
Status: Retrieving directory listing…
Command: PWD
Response: 257 “/” is the current directory
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode (87,98,153,17,198,85).
Command: MLSD
Error: Connection timed out
Error: Failed to retrieve directory listing

When I disable Firewall, the ftp client can access to ftp server. I think this is a firewall problem which doesn’t allow passive port.

  1. Interworx license

I’ve this message in the panel :

WARNING This control panel license will expire in: 8 hours 22 minutes 19 seconds
when I click on the message, the error is :

A system error has occurred. Please try your request again in a few minutes.
If the problem persists, please contact Support.
and the last problem :smiley:

  1. Softaculous

When I enable softaculous plugin I’ve this error :

softaculous: plugin disabled: Can not find /var/softaculous
If you have an idea ?

Thanks in advance for your answer :slight_smile:

PS : Interworx run on VPS on Proxmox system (openvz)

Now, Softaculous and license problem’s are ok lol :D.

But I always have the FTP problem ^^

Hi Gimly,

Regarding the FTP problem, you may want to try active mode rather than passive mode in the FTP client. If the problems continue, feel free to open a support ticket so we can investigate.


Ok thanks paul but, with the fw enable on Iworx, we can’t used passive mode ? O_o

Hello Gimly,

What did you do to fix softaculous?

softaculous: plugin disabled: Can not find /var/softaculous

I just installed a new interworx on new server and faced with same error when trying to enable plugin.


I found the problem - I had set apache to force php to use iworx user instead of apache. Changing this back solved the problem unfortunately.

I am really against PHP using apache as user - its a real shame because it allows the idiots to exploit a php based site easier as its harder for us to pinpoint the culprit.

Ah well - java hosting rules! I don’t think we’ve every had a java site get exploited. The worst that ever happens is we get newbie coders getting their code stuck in endless loops, but thats easy to catch and shutdown.

Anyway enough rambling on… Good night.

Softaculous should be comptable with suphp (aka the Run Scripts As the SiteWorx User). If there’s a problem using it with that mode on, we should look into it.


Hello Paul,

Would you like me to submit ticket so you can tinker? This is brand new server - just got it up and running. No customers on it yet, but soon.