Mysql is shutting down at 4am on sunday

I am running two newly installed interworx servers, and on both of them for the last two weeks, at 4:02 on Sunday morning, mysql stops, and basically takes down all of my sites.

Version: ‘5.0.48’ socket: ‘/var/lib/mysql/mysql.sock’ port: 3306 Source distribution
071125 4:02:04 [Note] /usr/libexec/mysqld: Normal shutdown

071125 4:02:04 InnoDB: Starting shutdown…
071125 4:02:05 InnoDB: Shutdown completed; log sequence number 0 8813459
071125 4:02:05 [Note] /usr/libexec/mysqld: Shutdown complete

071125 04:02:05 mysqld ended

I can’t find any crons scheduled to run at that time. Any ideas what it causing this to automatically shut down and not restart?

I did see that the MySQL auto-restart option in Nodeworx was set to off. Will changing this setting be enough to keep things running next week?

Changing the setting for MySQL auto-restart seems to have fixed it. Strange that this would be off by default.

Sorry to bump a 4 years old topic but I did noticed the same problem, on Centos 6, didn’t tried enabling the auto-restart option yet, anyway I see that as a workaround and not a solution… auto restart is good if the service crashs and needs to be restarted… however this doesn’t seem the case, iworx is really shutting mysql down apparently… why?

I did checked all logs (at /var/log/ and at /usr/local/interworx/var/log/) and noticed that at the same exact time (sunday 3:13 UTC) that “main” mysql have been shutdown also iworx-cp httpd as well as iworx mysql have been also restarted, these have been restarted with no problems but main mysql have been just shutdown, not started again…

Someone from iworx staff please… is it really intended to restart main mysql at sunday along with iworx services? if yes there must be something wrong as mysql just shuts down… else maybe some “wrong” way to restart iworx mysql is being used and is also shutting down main mysql?

Not just you, this is a “real” problem, mysql gets shutdown, presumably by iworx at @4am EST on Sunday.

Why? I don’t know, but obviously not good to just shutdown the production DB and not restart it.

Can an iWorx staff member chime in here, need to get this resolved, only just switched to our new server and need services running 24/7


well I did had the problem 3 weeks ago (when I made the above post), but for some reason on last two sundays no problem at all (and I didn’t enabled the auto-start option)… I did looked at all logs after the last two sundays and I can see that iworx restarted his own mysqld, but not the “main” mysqld, like it did 3 weeks ago… why? no idea…

one thing I do remember… few days before the 3 weeks ago problem happening I did changed some (main) mysql configs and restarted mysql using the option on the iworx web ui (at start page)… maybe that uses some different way to restart mysql (not by OS scripts) that somehow causes the problem (a possible mess with both main mysql and iworx mysql instances, like a file storing daemon pid or something similar…) on next sunday after it? just speculation… but must exist a reason why 3 weeks ago problem happened (restart affected both main and iworx mysqld’s) and not on last two weeks.

I could really test and try to find it if iworx could be so kind to provide me an extra 1 domain license to use on a test environment, indeed I did asked for it as I’d like to test this and some other things, but unfortunately staff told me they don’t provide such 1 domain free licenses anymore :frowning:

Yep, that test license was mighty useful :wink:

I’m going to keep tabs on it, my shutdown is at exactly 4:03AM on Sunday.

This issue seems to have resolved itself (for this Sunday at least)

In my case, I was transitioning between an old server and a new server. The interworx license remained active on the old (production) server while I tested the new server.

Could have been an issue with a non-activated license. Anyway, post-activation the issue did not occur this week on the new production server. Will post back if the problem crops up again.

and…v4.x branch rocks :wink: (was back in the stone ages with v3.0!)