MySQL Server version: Unknown


I reinstalled one of our VPS (Centos 6.6 x64, IW 5.0.15-700) and I discovered that the MySQL server not working good. In NodeWorx the version of MySQL is unknown and the MySQL Server Options are empty. In SiteWorx, when I try to create a database I can see only the following message: MySQL server not running.

It’s a clean install without modifications made 2-3 ours ago.

Do somebody have any idea what could be wrong?

Hi dss

That’s the second user to state MySQL not working upon a fresh install of IW on vps

What is your vps

Also, I’d open a ticket to let IW have a look to see what’s going on

I hope that helps

Many thanks


Hi John,

Thank you for your reply! It’s a small OpenVZ VPS with 1GB of RAM. As I remember the older versions were good on the same VPS.

Hi dss

Many thanks, and sorry, I’m sure you have but what comes to mind quickly with openvz, did you enable second level quotas

If not, I suspect this is the issue

Hope that helps

Many thanks


Hi John,

My previous post was wrong, it’s not OpenVZ it’s KVM.

Hi dss

Many thanks

Have you tried to manually start MySQL from ssh.

If so, did you note any errors or are there any errors shown in install log for IW

I’m wondering if perhaps a download link has been set to wrong address/reference, as this seems to have appeared directly after centos 7 pre beta were released.

I could be entirely wrong though, so apologies in advance.

I will try to do a fresh test install myself tonight or tommorow on centos 6, and see if I have same issues, but I would open a support ticket as it is most unusual

I’m sorry I can’t be any more helpful at this moment

Many thanks


Hi John,

Yes, I tried. I didn’t find any error in the log files. As I remember the working install was before the CentOS 7 release.

I checked the remote servers in MySQL settings (I don’t know why because I don’t have :D) and find this:

After clicking on Reactivate Server it asks for the database root username / password.


Hi dss

Many thanks, I think that helps a lot.

I’m thinking more then before, it is pulling from a pre beta centos 7 area when first running IW install, and therefore may look for remote server, with centos 7 been partitioned (sorry for wrong wording, just cannot remember the correct term used for centos 7)

I’ll let you know how my install goes, but it will be on a physical server not vps, but at least it will answer my theory of above

Many thanks


Hi John,

Thank you, I’m waiting for your experiences!

I checked the MySQL version of the affected server and a working (physical) server, you can see below:

[root@srv2 ~]# yum list installed | grep mysql
mysql.x86_64                        5.1.73-3.el6_5            @base
mysql-devel.x86_64                  5.1.73-3.el6_5            @base
mysql-iworx.x86_64                  4.0.21-12.rhe6x.iworx     @interworx-release
mysql-libs.x86_64                   5.1.73-3.el6_5            @updates
mysql-server.x86_64                 5.1.73-3.el6_5            @base
php-mysql.x86_64                    5.3.3-40.el6_6            @updates

It’s a known issue, you’ll need to contact InterWorx as it is very complex to fix, what the issue is that you installed it when the mysql repo wasn’t available, so it installs it after and that causes the wrong hash. They can fix it for you in about 16 minutes.

Hi Dss
Many thanks Mike (Licencecart), I did not know that, but good to know for future.
I was going to post anyway and state my theory was completely wrong, as a test install went lovely first time, all working as expected.
Dss, below is the output, so it looks like we match.
I’m sorry I was not able to help but glad it is an easy fix
Many thanks
Last login: Wed Jan 7 21:39:56 2015 from nnn.nnn.nnn.nnn
[root@localhost ~]# service mysqld status
mysqld (pid 1812) is running…
[root@localhost ~]# pgrep -u mysql mysqld
[root@localhost ~]# yum list installed | grep mysql
mysql.x86_64 5.1.73-3.el6_5 @base
mysql-devel.x86_64 5.1.73-3.el6_5 @base
mysql-iworx.x86_64 4.0.21-12.rhe6x.iworx @interworx-release
mysql-libs.x86_64 5.1.73-3.el6_5 @base
mysql-server.x86_64 5.1.73-3.el6_5 @base
php-mysql.x86_64 5.3.3-40.el6_6 @updates
[root@localhost ~]#

Hi dss and mike

I’m sorry, my fresh install last night on a test server, using centos 6.6 64 bit, full server and IW cp 5.-15 is showing the same error as dss reported here., exactly.

My mistake was to see IW-cp up and running, and ssh showed MySQL running, as did the default home page of nodeworx after first logging in.

I appreciate what mike has posted, but with 3 different users installing fresh IW on 3 different platforms on different days, I would be inclined to think that something has changed, unless it is a long term issue for downloading MySQL.

Either way, I would consider this not good and could be detrimental to IW if it’s not resolved fully.

I’ll open a support ticket after I have changed the test server to an external ip, incase they want to look.

Once again, sorry dss, I should have fully checked, but guess tiredness got the better of me sorry

Many thanks


Hi John and Michael,

Thank you for your replies and the tests!

Yes, everything looks good in NodeWorx until you don’t check the MySQL server settings. In my case it’s not too important to fix it because it’s a “DNS-only” and backup server so I can wait for the fix. I’ve just reported the problem because I didn’t know if it was an individual problem or not.


I was thinking about Mike post re hash causing issue due to repo not available, so I thought I would check when installed, which belows shows to me anyway, both MySQL repo available and installed in a timely fashion, with ver 5 first, then ver 4, so I am thinking it a little more then hash.
I could be wrong though, so apologies in advance.
Many thanks
Jan 07 20:12:16 Installed: mysql-libs-5.1.73-3.el6_5.x86_64
Jan 07 20:12:16 Installed: mysql-5.1.73-3.el6_5.x86_64

Jan 07 20:12:19 Installed: mysql-devel-5.1.73-3.el6_5.x86_64
Jan 07 20:13:01 Installed: mysql-iworx-4.0.21-12.rhe6x.iworx.x86_64

150107 20:12:21 [Note] /usr/libexec/mysqld: ready for connections.
Version: ‘5.1.73’ socket: ‘/var/lib/mysql/mysql.sock’ port: **** Source distribution
150107 20:18:20 mysqld started
/home/interworx/bin/iworx-db: ready for connections.
Version: ‘4.0.21’ socket: ‘/home/interworx/var/run/mysql.sock’ port: **** Source distribution
Note **** replaces correct port number


Sorry, it is a hash issue, IW have just confirmed this.

IW hopefully should be fully resolving before long, so normal installs can take place without issues.

Thanks to dss for raising this, and everettmarshall, who suffered the same issue, but in the meantime, of anyone experiences this issue, I would advise open a support ticket with IW, who will be able to correct it.

Many thanks


Just come across this issue on a fresh centos 6.6 install. Any ideas on how to fix this as due to my setup the server cant be accessed externally via ip (which i think the support team will ask for)

Interworx CP v5.0.15
mysql-5.1.73-3.el6_5.x86_64 already installed and latest version

Hi mhudson

I don’t think it can be corrected without ssh access.

I know IW have included this in their meetings and will correct it so it installs correctly first time as it should.

If you prefer to attempt yourself and you have ssh access, you need to add into my.cnf the part for hash=1, sorry, it’s late here and I’ll need to lookup the exact line, which is missing.

Then you need to rehash the password and restart MySQL

That then should restore service.

If however, you have ssh access, then you would be best advised to open a support ticket with IW and let them correct the issue. If you have any doubts over security, the remote support means they don’t use your access credentials.

I hope that helps

Many thanks


John thanks for the prompt response.

I had a feeling you would say that SSH is required for the support team to fix it. Unfortunately its not possible for them to SSH onto my server as its behind a secure firewall etc.

If you could provide the exact line i need to add i’m more than happy to try and sort it myself (and it may help others in the same situation)

I appreciate that timezones make things more fun so im more than happy to wait until you can make a reply. Unlikely to have the time to work on changing the set up until monday anyway :slight_smile:

Hi Mhudson
Many thanks, but I can assure IW are genuine and would not cause any issues, and to be sure you could change your passwords, before and after.
I understand the need for security, but as with everything, you have to trust some people.
In any event, please see below for how to correct, but if you cannot manage it, please open a support a ticket with IW. Honestly, those guys rock, and they have access to all our systems/servers, and we are a secure company (well, as much as anyone can say anyway), and our clients are a mixture of blue chip, educational and everywhere inbetween.
I hope that helps a little
Many thanks
old_passwords=1 was missing from /etc/my.cnf. I added it and skip-grant-tables and rehashed the password. I then removed skip-grant-tables and restarted mysqld

d2d4j have a solution working. IW CP still refused to communicate to mysql on localhost but setting up a remote server directed back to itself on worked fine after following your sugestions.

Its not that i dont want to let IW access the server. its the fact that its physically not possible with the combination of a dynamic public ip, firewalls and virtual machines.
Because its a dev environment its a total mess :smiley: Thanks for your help, you got me working ahead. hopefully by the time im happy with the site and setup they will have fixed the issue so i can smoothly move to a production enviroment