MySQL service won't start

Hi, my server has been running great, however just yesterday MySQL service won’t restart or start. I have tried starting it through the terminal and the nodeworx interface. Not sure why it won’t restart. Anybody else having mysql issues after the 10-18-16 upgrade?

Ver 14.14 Distrib 5.5.53, for Linux (x86_64) using readline 5.1# sudo /sbin/service mysqld start
MySQL Daemon failed to start.
Starting mysqld: [FAILED]

Do this:

mkdir /var/lib/mysql-files/
service mysqld restart

Hey ctalavera
That worked great, thank you so much. For my knowledge, what did I do, other than create a directory and restart the service. What happened, why did mysql not restart on its own?

Thanks again.

Apparently something changed where that directory is needed to execute secure files. The directory just needs to be created so that it has a place to look or store them I believe.

[QUOTE=ctalavera;29163]Do this:

mkdir /var/lib/mysql-files/
service mysqld restart[/QUOTE]

This tip saved me also.
Thanks :wink: