Newbie FTP Question

OK, I have been using Ensim, just added a interworx box, and for the life of me I can not figure out how to get my FTP program (SmartFTP) to log on to a site I set up on the box.

I have tried many set ups in SmartFTP, here is the fields I have to feel out in SmartFTP

Address: Login: Password: Port: 21

Lets assume my domain is “” and my username is: and my password is: 123456

In the Address window I have tried both and

In the Login; field I have placed

In the Pasword field I typed in my password 123456

All the different arrangements I tried will no let me log in.

This is a new box is ther sometime in nodeworx I might have forgottent to set up?

Can you confirm that the FTP server is running? Try restarting the FTP service via NodeWorx.

Here’s a setup that should work:

Password: 123456
Port: 21


I am set up in smartftp as you show in your post.

Using NodeWorx, the FTP shows to be running.

Then I stopped the FTP server and restarted it again using NodeWorx.

I went back to sitework and “reset” the ftp user password to make sure it was correct.

Then tried to log on via ftp again and I still keep getting this message through my ftp client:
An established connection was aborted by the software in your host machine.”

I am out of ideas.

Try changing the Active to Passive (or visa versa) in SmartFTP.

Tools --> Settings --> ‘connection’ - ‘mode’

Justec, thanks for the idea.

I tried that, changed from Passive to Actve, and still same problem. :frowning:

OK, this problem has been fixed. Was a problem with the FTP server.

In order to fix passive mode issues in APF + proFtpd:

Edit “/etc/proftpd.conf” and add the following line:

PassivePorts 50000 51000
Edit “/etc/apf/conf.apf” and add the above range to the Ingress ports.

Restart apf and proftpd.

I don’t have problems with SmartFTP and APF unless I’m uploading big binaries but that’s also with the older, stainless steel version of WS_FTP. Isn’t this an issue with FTP clients in general and not just a SmartFTP problem?

I think somewhere in this forum there’s a post about replacing proFTPd with pureFTPd which I think would help, especially for VPSes.