For some of my clients, I do not want to use Interworx-CP DNS services. So I created their acounts and then deleted the zones which have been automatically created for them from Interworx DNS Zones. Then I wanted to modify one of these domains, but iworx refused because of “bad IP address” (even though I didn’t change it). So I checked “Enable IP changes”, changed to different address with hope I’ll immediately change back to original IP address. But the original IP address isn’t available anymore, even though it is displayed as “UNUSED” both in IP management page and Reseller’s IPs page. I tried to remove it from the reseller, mark it is “not available to resellers” and back, but it didn’t help.

How do I create SiteWorx accounts without DNS services?
And how do I recover that lost IP address?

Thanks for help,


Re-add the DNS Zones that you deleted, with the correct IP address. Things will fall into place then.

Even if the DNS is hosted elsewhere, there is no need to delete the dns Zones from InterWorx - and in fact causes problems in the case of SiteWorx accounts as you’ve discovered. We’re working to make this more clear in the upcoming release.


Thanks for info. I didn’t realize I’d break it this way. Thought it would not allow me to delete the zone. Now I know.

As for the lost IP, I’ve already deleted the whole account, but I marked the IP as unused in database and it works again. I had also been missing another IP address - this one was for some reason stored in column “target” for some SOA records (but not all) in table dns_records in iworx database. I cleared them to NULL and marked this IP as unused in nodeworx_ips table too. Hopefully there are no relations/dependencies in the database which would become broken by these changes. Everything seems to work ok.

Thank you john.

I had solved it by reinstalling System Integrity Monitor (SIM) .This is not the same server which I mentioned in my first post.

I have just upgraded installed MySQL Ver 5.6 and PHP Ver 5.5 but most of the sites are showing database connection errrors like :


Using mysqli: Failed to connect to MySQL: ()
Using PDO: Error!: SQLSTATE[HY000] [2054] The server requested authentication method unknown to the client


I have updated all the database users pasword to new v5 hash format and sites started working , But Unfortunately I cannot manage MySQL server or phpmyadmin from IW control panel any more ​