NodeWorx System Error

I haven’t made any changes to InterWorx and have just let the updates auto install. But yesterday when I tried to login to NodeWorx I was getting a System error. I can’t remember exactly what it was because NodeWorx isn’t loading up anymore after doing a server reboot. But it had something to do with not being able to write to the disk. I’ve been using caching to the disk for one of the websites (through WordPress) and that seemed to increase in size rapidly on disk and went past the maximum I set for the SiteWorx account. I can only assume based on this I have run out of disk space?

I also disabled root login for SSH through InterWorx so I can’t login with root to view logs and make some space. Is there any way to re-enable the root login for SSH?

CentOS 7.2

I’ve got the option to boot into rescue mode with Ubuntu and switch to root user. But I can’t seem see any of the InterWorx content after I re-mount all the drives that it allows me to re-mount.

Apologies if this has already been covered off somewhere else but I did try a search but couldn’t find any topic with this issue. Any help is appreciated.

Hi dirtydex

I think I maybe the bearer of bad news sorry

From your description, the only way to make more space, or take any actions would most likely be through ssh (root)

Did you setup another user for ssh before disabling root login (this is normal before disabling root account login, so you log in as normal user, but then sudo and input password for root to gain root access - note, the user account has to be listed in sudo or you cannot sudo for root)

I guess not sorry, or you would not be asking

Do you have ftp access on any accounts - if so, you maybe able to gain more space by backing up the account and deleting it perhaps

I think you may not have easy access to your server, so is ot possible to have kvm access setup or remote hands, who can login locally as root (you would need to give them root password)

There is one possible way, as you can boot to safe mode perhaps, and that’s adjust the partitions, but this is something I have rarely done, and a few years ago sorry, so you may want to google that perhaps

Hmmm, actually if you can boot safe mode, could you not just clear your cache and tmp partitions

I hope that helps a little

Many thanks


Thanks for all your help John.

Managed to resolve this now. As you’ve said clearing the cache on the disk to free up space has resolved it.

I managed to do this in rescue mode. What I needed to do was sudo chroot the mounted drive so I could view the InterWorx user files.

I’ve created another user that can sudo with root access now :slight_smile: Lesson learnt.

Hi dirtydex

Glad you resolved it, and have a sudo account setup for root access

For everyone’s information, there is an Interworx support ssh account but this account is disabled unless it is activated. However, once activated, it is on a time frame before been auto disabled (you choose the time when the account auto disabled, from 24 hours upto a week I think from memory). So I did not mention the Interworx support account for access, as it would be not active

Lastly, have you setup any cron to auto delete from your cache or tmp, so this should not arise again

Many thanks


Good to know.

I’ve just realised the partition that is setup for root / only has a limited amount of space and that the partition with the most space is under /data which InterWorx doesn’t use. Would explain why I’m running out of space so quickly.

Once I’ve sorted that though I will setup a CRON job to delete cache and tmp.