Patching qmail - outgoing ip address selection

Hi guys,
This I really need your help with. I desperately need to patch qmail with following patch:

By default qmail-remote sends email from first ip adress on interface which on our server is not (and cannot be) the IP address of mail server. This causes problems with spam detection, SPF records settings etc. I really need to be able to tell qmail-remote which IP address to connect to external SMTP servers from. The patch allows it.

Since qmail comes from interworx-cp repository, I have no clue on how to proceed with patching it. Can, please, some of you guys give me needed hints?

Or even better, would you consider adding this patch to your qmail version? It does not change default behavior, just adds new feature. And it is a feature I think a lot of other interworx cp users would benefit from.

Thanks very much for help. M.


If you’re running interworx version 4.0 you already have an equivalent patch installed.

To set a default outgoing ip for all mail, add the following to a /var/qmail/control/bindroutes file:

To set the outgoing ip for a given domain only, add the following to a /var/qmail/control/senderip file:


Great. Thanks, I’ll try it.

My interworx won’t sent email too I’m not good on command line is there any other easy way John?

Hi dolla

I’m sorry no

The reason for this I suspect is IW have no way of knowing what IPv4 address or range your using

Also, IPv6 takes precedence over IPv4

Are you using IPv6,IPv4 or both

If not using IPv6, then you are better to disable IPv6

If your really struggling, please PM me but it’s not something I usually do and is easy to set

Are you not familiar with text editor in Linux

Many thanks


We are only using ip4 I know very little but we have live site that developers work I’m scared to broke all lol but reading everyday to learn. I think I need to rent one more vps for testings. Web developers doesn’t touch system :frowning: