PHP Problem

I bought an Order Form PHP script online and it won’t work on my server.

I tried it on another website of mine running Cpanel (and PHP v. and it worked fine.

Is it possible that the 4.2.x.x PHP version on my Interworx server is preventing the script from running? It won’t allow me to login to the ‘admin’ portion with any user/pass.

Is it possible to update the version of PHP without damaging anything on my Interworx server?

Check the php version on the other box and see if it’s different.

As for upgrading php, you can do that if you want and it won’t harm InterWorx itself (it runs it’s own instance of apache,mysql, and php apart from what the websites use), but that’s not saying you won’t break another script you have installed.

Good luck.


The one that it works on is v4.3.10.

And this is the only script I have installed =)

I tried updating PHP earlier and was unsuccessful =/

If you have InterWorx 1.9.0, which you should, then you also have PHP 4.3.10 installed on your InterWorx box. I’m suspecting the issue here is how PHP is configured on each box. Check the include paths on both boxes, and make sure they are pointing where they should, and check to see if “register_globals” is on or off on both boxes. You can do this by using the phpinfo() function.

I’ve ran all the updates (and it’s set to auto) so i suspect my Interworx is version 1.9.0.

But I ran a script (phpinfo) and it showed PHP version 4.2.2 I think.

So either i’m not at Interworx 1.9.0 or PHP didn’t get updated in the upgrade?

Did you check the values of register_globals on both the cPanel and Interworx server?

Hello all,

Trying to bring some light, I would like to point out that CentOS 3.3 boxes come with PHP 4.3.10 for iworx, but 4.3.2 as frontend PHP for websites. ‘yum update’ does not install a newer version.

# rpm -qa | grep php

If you make a file <?php phpinfo(); ?> and call it from browser, it shows indeed 4.3.2 version.

RedHat 9 updates up to PHP 4.3.9.

I’ve tried to upgrade PHP 4.3.2 up to 4.3.10 on a CentOS box, but I missed something because it didn’t work. Is there some other official interworx guidelines to update it?

Thank you very much.


There will be official releases of 4.3.10 for all platforms this week. We had shyed away from providing updates to PHP / Apache etc as we do not wish to become the defacto support source for those programs in addition to InterWorx-CP. We will however have an announcement this week layout out the terms of updates to these pakcages and have updates available.


Was PHP in fact updated to 4.3.10? From what I can see, an update to PHP was done but the version seems to be at 4.2.2-17.12.legacy? And i still can’t login to my database, which I can login to on another Cpanel server running the latest PHP =/

[root@centos root]# rpm -q php
[root@centos root]#


[root@redhat root]# rpm -q php
[root@redhat root]#

[root@redhat root]# rpm -qa | grep php

The rpm -qa option is supposed to show the installed packages, right? How come 2 different package versions appear? Is that normal? Was something not done right for Redhat 9 systems when the packages were updated for Iworx? And just for the record, yes the auto updating is checked, and it shows that on March 10th, it did an update to 4.2.2-17.12.legacy.

register_globals is ON on the cPanel box and OFF on the Interworx server.

The cPanel server is: PHP Version 4.3.10
The Interworx server is: PHP Version 4.2.2.

Could that be the reason my script isn’t working? How do i change the value of register_globals? =/

It is very likely why it does not work.

cp /etc/php.ini /etc/php.ini-back

vi /etc/php.ini

change register_globals = off to register_globals = on

It’s near the top. Be carefull not to edit anything else unless you have to.


oh and when you’re done editing, don’t forget to

service httpd restart

=) I rebooted the server … not realizing i had to just restart the httpd service.
Thought there was a restart for php alone but i couldn’t be bothered to find it.

I just rebooted and tried it and THAT FIXED IT! =) That is beautiful!

I’d still love to get PHP updated, but i’m so happy that fixed the problem.
Thanks so much, all of you =) If anyone has any suggestions on how to update my PHP permanently to 4.3.9 or whatever, please let me know =) Thanks again!

I assume your error was with one of your own scripts and not InterWorx itself as changing the /etc/php.ini would not effect InterWorx PHP.

One thing to note though, most PHP programs now should NOT require Globals ON by default as it is a security risk. So it’s good to hear your problem is fixed, but I would look into it further and see WHY that fixed it.

Just read the first post again:
“I bought an Order Form PHP script online and it won’t work on my server.”

So that script requires the globals to be on, I guess if you aren’t a PHP programmer there isn’t to much you can do about that.

Yep that was it - it was the script alright!

And i’m trying to get away from the script and i wanted to install whois.cart (recommended by Interworx) but when i did the diag check, i got:

"PHP version is older than recommended. The cart will still install and may well work without problems, yet we cannot provide technical support, and you are ineligible for our refund policy until PHP is up to date. "

I really want this PHP version updated. I really don’t know what else to do to update it =/ After reading my previous posts in this thread, has anyone got any ideas for me? =)

Erm … I’m showing this as my version of php (and I have 1.9.x installed)

Do you have a Redhat box? Probably not…?

For you guys that are still having issues with your PHP version, please open a support ticket so we can check it out.