php scripts won't work


got a server from sagonet and use interworx the first time. Got a problem with my phpscripts which worked on my old mashine with no problems. PHP is working but these scripts work with txt files, so I got the problem that nothing is written in it. dunno why. updated to 1.8.0 but the problem isn’t solved. I have 2 scripts tested yet but both won’t work. chmod is set to 777… but the script isn able to write or access the files…

does somebody know anything about this problem?

sorry for my bad english…

greetings from germany :wink:

Are you getting any errors at all that could help us debug the issue Kalky?


no php is working fine, the only problem is that nothing happens… no errors , but nothing were written. I thought it could be cause the older php version, but after your update to 1.8.0 it’s the same…

This sounds like purely a script issue Kalky and if I were to guess I’d say that the paths on your old server aren’t the same as the paths on the iworx-cp box, so it may be that you need to change the paths in your php scripts to reflect the actual files location on the iworx-cp box.


its not the first time that I transferred and used this script on other webspace… there are not pathes needed, the same to my galerie, its working there are no problems with pathes, but it does not create any new gallerie or the needed image folder


Can you drop me your root pass info, or just shell info for this account that has problems if you setup shell access and I’ll check it out.

Just use this secure form:


For the record, this is fixed. I had to turn register_globals ‘on’ for his PHP installation.


yep, big thanks, nice support there, no I go to bed, its 01:14 here :slight_smile:

kalky, just to advise yu that turn register_globals ‘on’ is not very secure.

Php try to turn off this feature. Use $_request $_post, $_get, $_xxxx instead

Maybe yu have to change you php script

Good luck


I’m having the same problem after upgrading to 1.8. I changed the globals to on and I still got no dice.

I’m running a phpBB site, and it’s just coming up blank… no errors or anything in the logs. :eek:

mangoat, look at this thread, it could help you