php update error


I just updated php 5.3.3 to 5.3.28 in the interworx -> software updates.
My problem is the php is still remained on version 5.3.3, even if i tried to reinstall package with “yum reinstall php-iworx”. The reinstall finished sucessfully but the php is still on 5.3.3.
Is anybody have an idea how can i fix this?

Thanks, Gabor.

Sorry for the late reply, you need to ensure you update the PHP via the repo, I don’t think Interworx is on 5.3.28 yet. I use 5.4.28 myself, I can help you upgrade to that?

thanks for the reply, I’m using the default release repo for updates.

There is 2 php installed in my server: “php-5.3.3-27.el6_5.i686” and “php-iworx-5.3.28-1.rhe6x.iworx.i686”.
I think the problem is interworx not using the php-iworx.

Which php is in interworx and siteworx used by default?
Can I configure somewhere which php module wanted to use?

Thanks, Gabor.

The iworx packages are only used internally by Interworx apr, and not used by apache for customer accounts.

This :slight_smile: the 5.3.28 is InterWorx PHP, 5.3.27 is your PHP for you. If you want the stable PHP 5.4.28 you can do the following:

rpm -ivh epel-release-6-8.noarch.rpm
rpm -Uvh remi-release-6*.rpm
yum --enablerepo=remi upgrade php-mysql php-devel php-gd php-pecl-memcache php-pspell php-snmp php-xmlrpc php-xml php-mcrypt

or if you want to update everything PHP, MySQL etc to their latest version you can just run this command:

yum install centos-release-SCL

And go to Server > System Updates > Update to ensure everything has updated.

In the Centos Release SCL package:

Ruby 1.9.3 (ruby193)
Python 2.7 (python27)
Python 3.3 (python33)
PHP 5.4 (php54)
Perl 5.16.3 (perl516)
Node.js 0.10 (nodejs010)
MariaDB 5.5 (mariadb55)
MySQL 5.5 (mysql55)
PostgreSQL 9.2 (postgresql92)

PS: It only updates what you have installed.

Thanks Michael for the solution, it works!

You’re welcome :slight_smile:

I have this error to ;/

For some reason

[I]yum install centos-release-SCL[/I]

doens’t work. It can’t find the package…the centos extras repo is enabled…

Anyone come across a similar issue?

Hi alanu

I could he wrong but I don’t think you have enabled the correct repo.

Yum --enablerepo=remi

I could be wrong though sorry

Many thanks


Hi Alanu

Sorry, I was wrong, and your yum command works for me (as below)

Many thanks


yum install centos-release-SCL
Loaded plugins: fastestmirror, presto
Loading mirror speeds from cached hostfile
epel/metalink | 26 kB 00:00

  • base:
  • epel:
  • extras:
  • rpmforge:
  • updates:
    base | 3.7 kB 00:00
    extras | 3.4 kB 00:00
    interworx-release | 2.5 kB 00:00
    interworx-release-noarch | 2.5 kB 00:00
    interworx-stable | 2.5 kB 00:00
    interworx-stable-noarch | 2.5 kB 00:00
    rpmforge | 1.9 kB 00:00
    updates | 3.4 kB 00:00
    Setting up Install Process
    Resolving Dependencies
    –> Running transaction check
    —> Package centos-release-SCL.x86_64 10:6-5.el6.centos will be installed
    –> Finished Dependency Resolution

Dependencies Resolved

Package Arch Version Repository Size

centos-release-SCL x86_64 10:6-5.el6.centos extras 3.9 k

Transaction Summary

Install 1 Package(s)

Total download size: 3.9 k
Installed size: 453
Is this ok [y/N]:

Thanks John,

According to the centos wiki, it’s part of the centos-extras repo.

yum install centos-release-SCLLoaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base:
 * epel:
 * epel-testing:
 * extras:
 * updates:
Setting up Install Process
No package centos-release-SCL available.
Error: Nothing to do

Hi Alan

I’m pretty sure you have enabled or loaded a repo, or perhaps you have a package set to exclude.

If you cannot find out which, and can wait an hour or so, I’ll put a pic up of the repos I have enabled, so you can compare.

I hope this is alright

Many thanks


Hi Alan

Please see our enabled repos on our test server as listed below.

are they enabled on your server, if not, and you enable them, does that resolve the issue, if not, please could you post your enabled repo.

Many thanks


CentOS-6 - Base base
Extra Packages for Enterprise Linux 6 - $basearch epel
RHEL 6 - - dag rpmforge
CentOS-6 - Updates updates
CentOS-6 - Extras extras


I need sites to run PHP 5.4.4 or better for latest Moodle and Joomla.

My PHP Integration Mode is showing 5.3.3 and PHP Mode is “PHP scripts run as SiteWorx user”
I followed the above directions and ran “yum install centos-release-SCL” It downloaded and installed.
Went to IW, Server, Software Updates and updated all. Still showing 5.3.3
Centos-6 Repos udpates and Extras enabled with no exclusions.
Still no luck so I “yum install php54” and all dependencies and then IW software updates… Still 5.3.3 I think Im missing a step;(

When I check my php install on centos I get the following:
PHP 5.4.16 (cli) (built: Jul 10 2014 10:06:38)
Copyright © 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright © 1998-2013 Zend Technologies

So its there I just can’t figure out how to tell IW to use it.

Any ideas do I need to change update channels? I have it set to release now. and OS updates enabled.


Hi Simchippy

Yes, I think you may have missed a few steps, which I have just tried and it also failed.

Please follow this as taken from Licencecart

rpm -ivh epel-release-6-8.noarch.rpm
rpm -Uvh remi-release-6*.rpm
yum --enablerepo=remi upgrade php-mysql php-devel php-gd php-pecl-memcache php-pspell php-snmp php-xmlrpc php-xml php-mcrypt

The update should fail, the reason is remi is not enabled as a repro. Goto nodeworx, server, softyware updates, and enable remi, remi-php55 and remi-php56 (if you only want say php55, leave remi-php56 disabled) from the repros list.

rerun the following from SSH

yum --enablerepo=remi upgrade php-mysql php-devel php-gd php-pecl-memcache php-pspell php-snmp php-xmlrpc php-xml php-mcrypt

To check it has installed the latest version, goto nodeworx, system services, web server, php info, and you should see the latest version (in my test, as I enabled php56, it shows as php 5.6)

Hope that helps, and once again, many thanks to Michael (Licencecart) for his excellent work on php.

A word of warning though, use updated PHP versions at your own risk, I have heard of PHP 5.6 having some inssues when used.



It sounds like you’ve installed PHP 5.4.16 correctly.

Interworx uses its own version of PHP, which is 5.3.3 due to dependencies, but this doesn’t effect any hosted sites you have, only the instances of nodeworx, and siteworx.

If you upload a php script to your site

<?php phpinfo(); ?>

, and then navigate to that script in the browser, what version is it giving you?

Hope that helps,



Hi Alan

Many thanks for posting, I considered that aspect, but the php info from system settings, webserver, should give you the correct PHP version used in apache I believe.

I could be wrong though, so I apologise in advance, and once again, thanks for posting, its good to know other users also help.

Many thanks


Hi John,

No you are quite right. I think our replies crossed. Indeed the reported version in “System Settings” > “Webserver” should give the apache php version and not the interworx version.

Michaels method that you mention works just fine, so hopefully this will fix simchippys issue.


Thanks guys for all the help and getting the php 5.4 working. It even started working without enabling the remi repo. Maybe because I already had the php update prior to following these steps. Two simple things that would make Interworx more competitive with the competition would be to have interface control of the php versions and an interface to edit the php setting in vs the php.ini, like cpanel.