Phpmyadmin 500 Internal Server Error (rejected), after Interworx update

I am having problems with my php my admin. It keeps giving error 500 when I try to change some property in any field of any table for example.

Error processing order
Error code: 500
Error text: Internal Server Error (rejected)
It seems that the connection to the server has been lost. Please check your network connectivity and the status of your server.

I can change information in a table, delete, insert content, when updating using the interworx software update system, it generated the following error.

Yum update failing: yum update ‘*iworx’
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

Dependencies Resolved

Package Arch Version Repository Size

interworx-phpmyadmin noarch 4.9.5-1784.iworx interworx-release 17 M

Transaction Summary

Upgrade 1 Package

Total download size: 17 M
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
Running transaction check
Running transaction test

I installed deltarpm and ran the yum update ‘* iworx’ command, but it returned that phpmyadmin is already installed. What can be done?


Hi Inventdigital

Welcome to IW forums

What IW-CP are you using

What distro are you using

Is the server a VPS

What does phpmyadmin show for version (click phpmyadmin and version will be bottom right of screen)

You could try the following

Restart Mysql

if not resolved

SSH into server and run as root or sudo

yum --cleanup-only or yum history redo last

yum update *iworx

Have you restarted the server or restarted Iworx - service iworx restart

If the above does not resolve, I would open a support with your licence provider and let IW have a quick look

Many thanks


Interesting i’m getting the same issue with phpmyadmin, I’ve tried to update, restarted mysqld, restarted the servers.

Seems since the last interworx phpmyadmin update.

Hi all.

This is a known issue, we are pushing a fix already. However the following will fix the issue now if you would rather not wait for the update.

cd ~iworx
tar xpf vendor.twig.tar
rm vendor.twig.tar

Hi Joseph

Thanks for posting that, its resolved it for me :slight_smile:

wow thanks, solved to me as well

No problem, sorry for the trouble. Took a while to figure out when it first came up as phpmyadmin docs indicated that the twig version we used was supported for the updated phpmyadmin version.

1 Like


Kudos to Joseph

I just checked on our servers (IW 6.8.0) and all are using phpmyadmin 4.9.5

We use RC so was pondering where this issue arose from, as it did not cause any issues to our servers and updated fine (we use Centos 6 and 7)

Many thanks


Not sure why you are not seeing the same issue. 4.9.5 and the 6.8 update is when the issues started.

Thanks so much for the fix.

It was my first time trying Interworx, so I thought my hosting provider setup something incorrectly on the new server.

What a relief! I’ll come here first next time.

If needed is also available to report issues. Thanks for trying out Interworx!!

Has this been pushed out to the main update yet? I don’t want to have to run this on 30 servers. To my knowledge, most of them are broke with the same issue as the OP and I’ve got tons of support tickets about the issue.

Hi falcon internet

I suspect it might be pushed to RC and follow the normal pushout timings for stable RC etc… kinda makes sense as stable should not have the issue but RC did

The fix provided by IW Joseph only takes seconds with no restart of any service I think

IW Joseph May confirm though

Many thanks



Unfortunately it looks like it was pushed out as a normal release so it was going through the normal beta, rc and then ga channels. I’ve asked that we rush it considering the phpmyadmin issues. Promoting the 6.8.1-1801 update to GA now. It will need to get through a large number of automated tests first but it should become available today.

thanks. i went ahead and applied the patch to the complainers, will wait on the others.