phpMyAdmin - Error

I haven’t made any changes to InterWorx and have just let the updates auto install. But yesterday when I tried to login to phpMyAdmin (for the first time since July) via NodeWorx and SiteWorx I keep getting the following “phpMyAdmin - Error” “Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly. Also ensure that cookies are enabled in your browser.”

  • I've tried different browsers - still the same error.
  • The PHP pages that use sessions are working okay.
  • The database used by the PHP pages are still working okay.
  • I've checked the logs and they don't to have anything in them relating to this.

Details:
CentOS 7
interworx-phpmyadmin version 4.0.10.17
InterWorx CP v5.1.34

I haven’t made any changes so I can only assume it was an update that has caused this to happen. Apologies if this has already been covered off somewhere else but I did try a search but couldn’t find any topic with this issue. Any help is appreciated.

Hi dirtydex

Welcome to Iw forums

Have you tried restarting Apache

I believe there was an update to phpmyadmin from memory, but this would have been a few versions ago

Also, if the above does not resolve it, can you restart your server - sometimes a restart resolves issues

Many thanks

John

Hi John

I tried both (restarting Apache and restarting the server) and I still got the same error :frowning: so I’m kind of stumped as to what else it could be (normally a restart of Apache or server does do the trick).

Hi dirtydex

Many thanks

There is new update, but changelog does not show for phpmyadmin but worth a try

It’s a RC update, ver 5.1.35 for IW

I’ve just tried on one of our production servers, works lovely but is centos 6

I’ll have to startup a centos 7 test server to see if I can replicate issue to help

Do you have debug mode set to on - nodeworx, server,settings, debugging options - debug mode

It may cast more light

Also, are trying from siteworx or nodeworx for phpmyadmin

I think you may also want to look at logs, interworx, error.log

I hope that helps a little, but with no error been shown, are you sure it’s not your browser allowing cookies

Many thanks

John

Hi Dirtydex
Please see this site which may help


I tried to replicate on Centos 7 Test server, updated distro and IW, worked lovely sorry, so it has to be one of the fixes on the above.
I would appreciate of you could update your post if resolved, and how you resolved it
Many thanks
John

  • Installed RC update, ver 5.1.35 for IW
  • Debug mode turned on
  • Tried for both SiteWorx or NodeWorx for phpmyadmin
  • No further errors related to this under InterWorx -> error.log
  • Tried various browsers and Internet connections and still not working.

I’ll try the link you’ve posted and keep you updated. Thanks again for all your help.

I’ve tried all the above including the link but it is still producing the same error :frowning:

Hi dirtydex

Does it do the same if you try private browsing

Have you cleared your browser cache and cookies in full

Have you cleared you /tmp folder on server

In your php.ini, is you session set to files and not memcache, and you have not set session secure I think it’s called

Is it possible to pm me a login to nodeworx or siteworx account, which is a test site only

What are your permissions on your /tmp and var/tmp and also on ~iworx/tmp

Many thanks

John

Does it do the same if you try private browsing - Yes
Have you cleared your browser cache and cookies in full - Yes
Have you cleared you /tmp folder on server - I haven’t tried this. What I did instead was change the directory in the php.ini for session.save_path to a new folder named “temp” with 777 and it did the same thing.
In your php.ini, is you session set to files and not memcache, and you have not set session secure I think it’s called - session.save_handler = files
Is it possible to pm me a login to nodeworx or siteworx account, which is a test site only - Will PM you :slight_smile:
What are your permissions on your /tmp and var/tmp and also on ~iworx/tmp
drwxrwxrwt. = var/tmp
drwx------ = ~iworx/tmp
drwxrwxrwt. = /tmp

Hi Dirtydex
Many thanks, and sorry, I am about to finish for the night.
I had a quick look at your PM, and confirm it shows the same on my browser, had to create a test database though, or it would not show anything anyway.
Please can you check and delete as need - I tried quickly on a test server, and deleting the sessions did not break anything on our test server, but once deleted, you will need to log out of nodeworx, refresh and log back in again. This then creates the session for phpmyadmin, when accessing phpmyadmin.
I do believe it is connected with a setting, which may have changed, and please remember, IW runs its own PHP/Mysql/services which are seperate to apache, so I am thinking any changes you have made, were to apache php.ini and not IW php.ini.
The location of myphpadmin maybe different on your centos 7, as I tested tonight using a centos 6 server, but same versions of IW, phpmyadmin etc…
I hope that helps, and if it still fails, I would open a support ticket with IW, those guys rock, and please can you delete the test account you setup.
Many thanks
John
Sessions to delete
/usr/local/interworx/lib/phpMyAdmin3/sessions
/usr/local/interworx/var/session
PHP to check (/usr/local/interworx/etc/php.ini)
Handler used to store/retrieve data.
session.save_handler = files
session.save_path = /home/interworx/var/session
session.use_cookies = 1

session.use_only_cookies = 1
session.name = PHPSESSID
session.cookie_path = /
perms to check
/usr/local/interworx/var/session
drwx------. 2 iworx iworx 12288 Nov 12 21:06
/usr/local/interworx/lib/phpMyAdmin3/sessions
drwx–x--x 2 iworx-pma iworx-pma 4096 Nov 12 20:58

You are an absolute star! Thank you for all your help :slight_smile:

The following resolved the issue for me:
/usr/local/interworx/lib/phpMyAdmin3/sessions

The sessions folder didn’t exist. I created a new sessions folder within /usr/local/interworx/lib/phpMyAdmin3/ and used the same permissions as the other folders within /usr/local/interworx/lib/phpMyAdmin3/ e.g. js folder. As soon as I created this and logged out of InterWorx CP and logged back in I was able to access phpMyAdmin.

[QUOTE=dirtydex;29197]You are an absolute star! Thank you for all your help :slight_smile:

The following resolved the issue for me:
/usr/local/interworx/lib/phpMyAdmin3/sessions

The sessions folder didn’t exist. I created a new sessions folder within /usr/local/interworx/lib/phpMyAdmin3/ and used the same permissions as the other folders within /usr/local/interworx/lib/phpMyAdmin3/ e.g. js folder. As soon as I created this and logged out of InterWorx CP and logged back in I was able to access phpMyAdmin.[/QUOTE]

I got bit by this error today… the server’s on InterWorx-CP v5.1.41, though. Incidentally, what was the chmod permissions you used? I’m for some reason having a major case of the stupids right now.

Edit: I wanted to note that doing this resolved the issue for me as well.

Hi keiro
Glad it resolved for you
The permissions for session folder I believe should be
/usr/local/interworx/lib/phpMyAdmin3/sessions
drwx–x--x 2 iworx-pma iworx-pma 4096 Nov 12 20:58
chmod 0711 /usr/local/interworx/lib/phpMyAdmin3/sessions
Many thanks
John

This problem still exists! Latest available version (5.1.41-1262), clean install.

Hi dss

I hope your well

Please could I ask if the above resolves it for you and if you can see the iworx db shown as well as localhost

Many thanks

John

After creating sessions folder with the correct permissions everything is working fine! InterWorx DB is also visible.

This problem still exists! Latest available version (5.1.50-1292), clean install.

Gewoon IT - Mart Dirks

Hi gewoonif

Many thanks and I’ve forward the thread to IW

Just so I’m clear, does the workaround in this post work for you, so your just posting to let know the installer has not been corrrcted

Many thanks

John

Hi d2d4j,

Creating this folder…

/usr/local/interworx/lib/phpMyAdmin3/sessions
drwx–x--x 2 iworx-pma iworx-pma 4096 Nov 12 20:58

…solved the problem.

The problem exist still in the installer.

Gewoon IT - Mart Dirks

Hi gewootnit

Many thanks

I forwarded this thread to Iw, so it’s kept in mind but as I understand it now, this is a hard issue for them to track down, as it is inconsistent and cannot be replicated on every install

Patience I think is needed and as it is easy to correct, should not present any real issue

Many thanks

John