phpmyadmin problem ??

i have a problem with phpmyadmin 2.6.2 the zip or gzip for compression backups does not work.
when trying to use the option all i get is a very small file of about 100k and i know the database is quite large.
also if you try and open the zip or gzip file it says its curropt.

i have tried to find the problem but no luck so far, was going to upgrade to the latest phpmyadmin version to try and resolve my problem that way but thought i better ask up to what version interworkx supports ??

unless anyone has any ideas what to look for in regards to why zip or gzips not working.

thank you

No further with this and i have found its only applys to one domain/account all the others are ok.

anyone know what to check for or would it be easier to backup the account and delete and recreate and then reinstall the backup of the site ??

Have you tried creating the dump and compressing it directly on the server (not via phpMyAdmin but on the command line)? After creating it on the command line, try downloading it, either via FTP or SCP.


yes i can do that to get the dump file but was trying to fix or find why phpmyadmin
gzip & zip compression option is not working on that account.
thanks for your reply

ok i have pinpointed this problem to large databases (800mb)
i can select all the tables using export except for the largest table and gzip and zip works fine.
if i try to use the gzip or zip option on the whole database which is 800 mb plus then the zip file is currupt and that option does not work.

so is this an error or bug or is large database compression not supported.

thank you

You’re not the first one to have this issue, but I’m not sure if it’s a bug in phpmyadmin or if they just don’t support it in that version for some reason. Socheat might know.

Some clients have done installs of the current phpmyadmin for their own use (apart from the Iworx provided one) untill we release an update.

ie install it in or whatever :slight_smile:

installed the latest phpmyadmin as a stand alone but still had the same problem, so give up on that one.
using either shell to gzip or phpmybackuppro which does the job ok.
thanks again for your replies


I presume tha the error is something like
If error “ERROR 1153 (08S01) at line 197: Got a packet bigger than ‘max_allowed_packet’ bytes”;

  • in other ssh console, do

mysql -u root -p

> set global max_allowed_packet=1000000000;
> set global net_buffer_length=1000000;

(leave the console window open)

restore backup or dump db …

after done, return to the console to exit mysql

I’ve restored a 1,6Gb mysql db this way and no problems with it :wink: