Piping emails to a file on another interworx account (same server)

Piping works just fine when piping an email to a file on the same siteworx account, but I need to get it piping to a file on another siteworx account.

When trying to do this, I’m not seeing anything in the error logs at all regarding this (I can see the successful pipe, but not the unsuccessful ones). I’m guessing this might be a permissions issue? If so, anyway to get it working?

If I try to pipe it to /usr/bin/php /chroot/home/domain1/domain1.com/html/pipe/ it works, but not to /usr/bin/php /chroot/home/domain2/domain2.com/html/pipe/

Hi staxed

I think this could be a security risk to domain2, but without knowing why you want to do, it may or may not be.

I think you need to add the unix name of domain1 to domain2, which should then allow permissions to access the folder. Ie chown and chmod

If you want to see what I mean, turn on ssh for domain1, then ssh and try to gain access to domain2

There is another way, but you may prefer not to use this method if available, and that is to set a cron for email collection into your app.

I hope that helps

Many thanks


They are both hosting our business websites on a vps that’s only for our own websites, no clients or anything on that vps so no security risk to think about with it.

As for cron, cron is what is used to run the piping, so that’s already configured…but doesn’t work because of (what I’m assuming is a permission issue), hence the reason I’m asking :slight_smile:

When you say add the unix name of domain1 to domain2, what exactly do you mean? Within Interworx itself or directly via root?

Hi staxed

Many thanks

Yes, directly via root from ssh

I would edit the domain1 siteworx account from nodeworx to find its unix name, then ssh into server and lookup the permission of current siteworx user to the exact folder, then add domain1 as a user and set the correct permission.

This then should overcome write permission on the folder.

I hope it helps and sorry if I’m wrong

Many thanks


Since you are already doing a cron then you could just run the cron as a privileged user, not necessarily root, but at least one that has access to all the accounts. That should take care of the permissions issue.