Possible Bug with Interworx Apache Config

I’ve been having several issues with various servers reporting down due to MaxClients getting reached. However, when I look at the Web Server graph in Interworx, it RARELY goes above 12. When looking in /var/log/httpd/errror log, I see many errors about Reaching the MaxClients, but it’s never going about about 12.

So after some research, I realized that the MaxClients setting in /etc/httpd/conf/httpd.conf is being set BEFORE the ServerLimit directive. ServerLimit needs to be set first, or MaxClients will default to 10.

After setting this, I’ve seen a HUGE improvement in load times and server down messages from my Pingdom monitor. Plus, if you have Auto-Restart apache on in interworx, Apache is getting restarted constantly on busy servers.

I am curious to know what others think about this and to know whether or not I am just a bit crazy.

I could be wrong, there is a file called /etc/httpd/conf.d/swtune.conf in a virtual machine (OpenVZ) that is overriding the settings set in Interworx. Deleting this file fixes the problems.