Possible CPanel Import error for missing "ssldomain" folder

Was running an import for a client from a CPanel account and it kept failing on

[B]? MESSAGE: file(/thetempdirectoryhere/cpanelImportABC123/theimportpackage/ssldomain): failed to open stream: No such file or directory[/B]

I just extracted the backup files from the package, found a folder called “ssl,” renamed it to “ssldomain,” then packaged up the files again and then the import worked fine.

I said “possible” bug since I’m not sure if there was something weird in this package or if this is just a new format from CPanel that needs to be taken into account on the IW importer side.

A follow up to this, the import had several secondary sites which imported ok, but was getting the following error:


You don't have permission to access / on this server.
Server unable to read htaccess file, denying access to be safe

Turns out the secondary domain directories were set as drwxr-s—, changing them to drwxr-sr-x solved the issue.

Hi Justin

Kudos to you and thanks for posting issue with resolution.

I?ll forward your thread to IW so there aware as it could be a cpanel change of format perhaps

Hope you have a lovely weekend

Many thanks



We haven’t had any other reports of issues with cpanel imports, but there could be something new we’re not aware of. What version of Cpanel were you importing from? Would you be able to submit a support ticket and attach the Cpanel backup you were importing so we can attempt to reproduce the issue/investigate? Normally, I would recommend having your hosting company submit the ticket, but easy enough to cut out the middle man in this case. :slight_smile:

You can submit the ticket, here: https://support.interworx.com/


Hi Jenna, I’ve submitted a ticket just now with download link.

cPanel Version I was given was 72.0.10???

Sorry to bump in this old thread, but same happened to me today after importing a cPanel account and subdomain in cPanel.
Mentioned solution works: Turns out the secondary domain directories were set as drwxr-s—, changing them to drwxr-sr-x solved the issue.

NOTE: when adding a new subdomain in siteworx the filerights are OK so it is the cPanel import failing to do so.

Kind regards,

Hi nico

Good post and I am sorry, I am not sure if CPanel update has been pushed out

It looks likely not if you had same issue with same fix

Kudos to justec, he?s very knowledgeable and helpful

Many thanks