Problem creating email alias

So, I have had the problem a while and can’t seem to figure out the problem. When I go into Siteworx > Email > Aliases and try to make an alias I get this:

So, first place I looked was the Interworx Log files and I see this:

[Mon Oct 26 16:06:13 2015] [error] [client ***.***.***.***] sh: /home/vpopmail/bin/valias: Permission denied, referer: http://***.***.***.***:2080/siteworx/email/alias

So, next, I log in thru ssh and check the permissions on valias and see this:

-rwxr-x--- 1 vpopmail root 3898402 Jun  4 14:43 vadddomain
-rwsr-x--- 1 vpopmail root 3896460 Jun  4 14:43 vadduser
-rwxr-x--- 1 vpopmail root 3892197 Jun  4 14:43 valias
-rwxr-x--- 1 vpopmail root 3890224 Jun  4 14:43 vchangepw
-rwxr-x--- 1 vpopmail root 3922058 Jun  4 14:43 vchkpw
-rwxr-x--- 1 vpopmail root 3903975 Jun  4 14:43 vconvert
-rwxr-x--- 1 vpopmail root 3890677 Jun  4 14:43 vdeldomain
-rwxr-x--- 1 vpopmail root 3926225 Jun  4 14:43 vdelivermail
-rwxr-x--- 1 vpopmail root 3893263 Jun  4 14:43 vdeloldusers
-rwsr-x--- 1 vpopmail root 3888820 Jun  4 14:43 vdeluser
-rwsr-x--- 1 vpopmail root 3895942 Jun  4 14:43 vdominfo
-rwxr-x--- 1 vpopmail root 3889309 Jun  4 14:43 vipmap
-rwxr-x--- 1 vpopmail root 3888399 Jun  4 14:43 vkill
-rwxr-x--- 1 vpopmail root 3961915 Jun  4 14:43 vlist
-rwxr-x--- 1 vpopmail root 3887170 Jun  4 14:43 vmkpasswd
-rwxr-x--- 1 vpopmail root 3928141 Jun  4 14:43 vmoddomlimits
-rwsr-x--- 1 vpopmail root 3897292 Jun  4 14:43 vmoduser
-rwsr-x--- 1 vpopmail root 3889348 Jun  4 14:43 vpasswd
-rwxr-x--- 1 vpopmail root 3904574 Jun  4 14:43 vpopbull
-rwxr-x--- 1 vpopmail root 4011598 Jun  4 14:43 vpopmaild
-rwxr-x--- 1 vpopmail root 3890914 Jun  4 14:43 vsetuserquota
-rwxr-x--- 1 vpopmail root   65607 Jun  4 14:43 vusagec
-rwsr-s--- 1 vpopmail root 3901838 Jun  4 14:43 vuserinfo

Now, with previous experience with linux. It’s normally “vpopmail:vchkpw” as user and group. I’m not sure how it would of gotten changed if it is suppose to be that. But I’m not sure how Interworx sets it all up. You would think that after having it over the past 4 or 5ish years I would know, just never paid attention.

Either way, I’m still getting the error. I have tried vpopmail:vchkpw and vpopmail:iworx just in case to see if that was suppose to be it. I’m not sure what group it needs to be in for Interworx. Any help would be great. Thanks!

I just checked my server and it’s vpopmail:vchkpw like you first thought:

-rwxr-x--- 1 vpopmail vchkpw 3898402 Jun  4 14:43 vadddomain

Did you check the directory permissions above that? If the bin directory is also set to root, then that might prevent it from working even if you change the executables here to vpopmail:vchkpw

Hi Joshfow and Justec
I read this yesterday, but could I ask if this is only on 1 domain or does it affect all domains.
If on 1 domain, then I would try ssh into server, run ~iworx/bin ./vpopmail.pex --fixPerms domain.url (where domain.url is your actual domain with issue)
Also, in your posted perms, you valias does not match on our test server, which is set to 4750
yours -rwxr-x— 1 vpopmail root 3892197 Jun 4 14:43 valias
ours -rwsr-x— 1 vpopmail vchkpw 3892197 Jun 4 19:43 valias
I suspect the permission error is on this file only, and you need to reset back to vpopmail:vchkpw. Infact, it might be a good idea to run ~iworx/bin ./varpermsfix.pex as well.
I hope that helps a little
Many thanks

I’m trying to post a response but I keep getting:

Post denied. New posts are limited by number of URLs it may contain and checked if it doesn’t contain forbidden words.

I’m not sure why, I don’t even have any URLs in it.

So, I put my response here:

Joshfow reply


  • Thanks for the replies. I ended up reinstalling vpopmail with yum so it would grab the iworx version and it seemed to of fixed the user and group for all the directories and files. I'm still getting the same error though :/
  • I went ahead after that and ran both of your suggests and I'm still having the same problem. And to answer your question, it's across all domains. We have roughly 25 domains on the server.
  • Also, it seems that another problem has come up. Now, my local qmail queue isn't processing.
  • Here is the maillog:
  • ``` ****** maildrop[10688]: Unable to open filter file, errno=13. ```
  •, we aren't getting our email too. They may not be related but it almost seems like everything is falling apart at one time, lol. I will say, it looked like something happened to my group file because the vchkpw group was missing altogether until I reinstalled vpopmail. I'm not sure what happened there. I never manually update the groups.


  • Thanks! It let you do it, lol. Maybe because I am new to the forums something hit a flag.

    Hi Joshfow

    Many thanks, a few questions
    What is your distro, IW version and is this a VPS or full dedicated server
    DO you have enough drive space free
    Do your clients have enough allocated space for email free
    Have you restarted qmail (service smtp stop then service smtp start)
    It sounds as though the second issue arose as a result of qmail reinstall - how did you do this reinstall
    Many thanks

    • We are running CentOS 6.7 with IW v5.10.
    • It is a full dedicated server and there is still plenty of drive space left. We are only using about 42% of 500 gbs.
    • And all users are set to unlimited space. Mainly because all the domains are ours. We don’t resell or anything like that.
    • I have restarted all the services and even restarted the whole server after the reinstall of vpopmail in case I missed a service.
    • To reinstall I did “yum reinstall vpopmail” and “yum reinstall qmail”. The errors for the “unable to open filter file” actually started before the reinstall. That’s why I think they may not be related. It kind of happened on it’s own at 2am when I was fast asleep :confused:

    On another note, it started about the same time that iworx updated php54 automagically. But I wouldn’t see why that would have anything to do with the issue.

    On another note, I just saw that qmail was updated automagically on 10-13. I haven’t restarted the services since. Could a config file of been changed in the update then a auto-restart of made it take the change early this morning?

    Hi joshfow

    It’s interesting you stated 2am, as on our systems, that the time auto update kicks in I believe.

    You could be correct, but none of our servers showed issues.

    It would be interesting to know if you create a new siteworx account, does this do the same

    The mail drop issue is filter file cannot be found or cannot open I believe, but this will be in IW db (MySQL )

    You may want to open a support ticket so IW can see what’s happening, if only to exclude IW upgrade to 5.1 causing issue.

    I personally do not think it is connected with php5.4, as it does appear to be permissions/file groups etc

    I hope that helps a little

    Many thanks


    That would make sense that the filter file is in the IW db. I know it’s usually a .mailfilter file, but I couldn’t find such a file. I went ahead and made a support ticket not long ago so they could take a look at it. Hopefully, they will be able to figure out the problem.

    Thanks for all you help. I’m about to take lunch now, but I will make a new test domain once I get back and see if I’m still getting the same problem with that too.

    Hi joshfow

    Many thanks and appreciate if you could update your post when resolved.

    Did you test on a new siteworx domain

    Many thanks


    I tried making a new siteworx domain and it wouldn’t let me add a new alias either. And this is the response I got so far:

    Hey Josh,

    I read your forum posts and what you did up to this point. I’m not sure what file maildrop is attempting to reference here, so I ran our permissions fix tool:


    Mail now appears to be flowing. I don’t see anyone else logged into the server, so I’m going to say this was this fix. I wish I had a better explanation for you, but it appears the problem was permissions related.

    So, our mail is going out, but I still can’t add new addresses. I will update this once that is all fixed too.

    Hi joshfow

    Many thanks, at least mail is flowing now. Apologies, I typed the wrong command by adding ./ when it should not have had it.

    Just a thought has occurred, but I’m sure it’s not it, but your trying to add an alias to a proper domain, not a pointer

    Sorry if your post makes clear, but on an mobile, the screen not large and my memory fading sorry

    Have you checked the permissions on you valias to those of mine posted

    Many thanks


    The permissions have been reset for all of the vpopmail stuff. And I’m trying to make it for the domain and not a pointer. I will add that I can’t edit existing aliases already made in the past. Also, I can’t change the catch-all too.

    Ok, another update. It has all been fixed. Here is their response:

    It looks like the iworx user was missing from:


    after adding it alias domains can now be created.

    So, it was nothing more than a missing entry to the users. I’m not sure how it disappeared but at least it’s fixed now. Thanks for all the help!

    Hi joshfow

    Glad it’s resolved and working. IW guys rock.

    Do you mind me asking if you have rkhunter and maldet installed. If not, you may want to install them

    I’m only asking because your not sure how it changed

    Many thanks