Problem installing Interworx !

Hi,
i have problems when i want to install interworx, here it is:

[root@h10-10 root]# sh iworx-cp-install.sh -u -k

FATAL ERROR: iworx-cp-install.sh requires 'rpmbuild' to be installed

Any idea of what should i do ? :frowning:

I’m assuming it’s asking for an RPM package that isn’t installed and that you have YUM installed:

try

yum install rpmbuild

I tried but it doesn’t work :frowning:

[root@h10-10 root]# yum install rpmbuild
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Fedora Core 2 - i386 - Released Updates
Finding updated packages
Downloading needed headers
Cannot find a package matching rpmbuild
No actions to take

Do you have any other idea ?
thanks for your help :slight_smile:

I just looked at a package listing in my Fedora Linux book try:

yum install rpm-build

This is a listing for FC1, but it shouldn’t matter.

Yeah !
thank you, it’s working now :slight_smile:
i hop there will be no other problems during this instalaltion :wink:

thank you again !

no problem. I hope you like InterWorx :slight_smile:

i think i’ll like it :wink:
it’s been since november that i’m coming on this forum, and while buying interworx, i’m sure of what i’m doing :stuck_out_tongue:

**** ! another problem :frowning:

I installed interworx and everything went well, except a the end, i ran:

sh iworx-cp-install.sh :D

and it told me: no path to sendmail or something like that… ok let’s continue…

In the next step (i’m following the iworx doc), i have to do that:

root@server# cd /home/interworx/bin
 root@server# ./goiworx.pex

so, i did it and that’s the result:

[root@h10-10 /]# ls
bin   dev  home    lib         misc  opt   root  selinux  tmp  var
boot  etc  initrd  lost+found  mnt   proc  sbin  sys      usr
[root@h10-10 /]# cd /home/interworx/bin
-bash: cd: /home/interworx/bin: No such file or directory
[root@h10-10 /]# ls home
[root@h10-10 /]#

What’s that ?? it took a while installing the iworx cp with updates and everything, and now it seems not to be installed :frowning:

rpm -q *.iworx

Let’s see what’s installed and what’s missing.

[root@h10-10 root]# rpm -q *.iworx
package *.iworx is not installed

:frowning:

and i tried to reinstall interworx, but this is the same result : nothing installed !

PS: timryberg, would you turn on your msn so i can contact you ?
thanks

[root@centos root]# cd /home/interworx
[root@centos interworx]# dir
bin cron EULA include iworx.ini iworx.ini.old lib nodeworx sql
CREDITS etc html ioncube iworx.ini~ lang LICENSE siteworx var
[root@centos interworx]#

That’s what SHOULD be there.

InterWorx does not use Sendmail, it uses qmail

run

# service iworx status

if it says it’s down run the command with start

If is says “unrecognized service” then you have a serious problem :frowning:

Just did, sorry. Disconnected from the Internet and forgot to log back into that earlier today.

so i have a serious problem :frowning:

anyone else who reads this I was wrong about the command earlier inthe thrad it’s

rpm -qa | grep iworx

There are all sorts of errors here, at my suggestion Roman has open a support ticket.

Roman,

did you launch the script as root ?

hmm not sure this one work, you should test this :

rpm -qa | grep iworx

Are you sure you are under root when yu did all these commands (dir, cd, ls, sh, etc …) ?

If you have a pbm, the best way should be to contact the iworx support team

Good luck

Pascal

yes i was under root :slight_smile:
i opened a ticket and chris is working on it…

ok, Chris installed Interworx, but when i want to run the prog to enter the liscence key i have the following error message:

----- DEBUG STACKTRACE BEGIN -----
/home/interworx/include/debug.php debug_printstacktrace (127)
/home/interworx/include/database.php debug_die (40)
/home/interworx/include/session.php db_connect (58)
0 session_read (0)
/home/interworx/include/nodeworx/NodeWorx.php session_start (504)
/home/interworx/nodeworx/html/index.php continuesession (37)
/home/interworx/nodeworx/html/index.php _il_exec (2)
----- DEBUG STACKTRACE END -----

/home/interworx/include/database.php(40): DB Error: connect failed

Any idea ?

Sometimes, if you encounter pbm installing interworx-cp it may due to some rpms dependancies pbms.

be sure you don’t have msg when installing interworx saying dependancies resolve : can’t resolve or something like this.

It usualy due to rpm or yum pbms.

So first be sure to have availbale uids 102 up to 107 for qmail in /etc/passwd and available guids 102 and 103 in /etc/group

Then you may try to do something like

rpm --rebuilddb
yum clean all

then relaunch the interworx script install under root

sh iworx-cp-install.sh

Pascal