proftp error (ftpusers)

since the proftp update i have been getting a lot of this in my logs, i checked and i dont have ftpusers file ?
i also checked the proftp.config and ftpusers is set to off ?
Should i create a ftpusers file and i think it contains users you dont want to use ftp, which users should be denied.
or can i disable the checking.
Thank you

pam_listfile(ftp:auth): Couldn’t open /etc/ftpusers
pam_unix(ftp:auth): check pass; user unknown
pam_unix(ftp:auth): authentication failure; logname= uid=0 euid=0 tty= rhost=##.##.##.##

Hi Gary,

This error isn’t critical and can be safely ignored. It’s looking for the /etc/ftpusers file, but it’s not needed and InterWorx doesn’t use it for ftp user management at all.


Ok thanks, how do i disable it from looking for the ftpusers file as on some days
there are loads of the messages.


it would be nice if you find a way to disable this error, because /var/log/secure is being rotated weekly and getting more than 1 million lines of this errors every week and I think a little change in /etc/pam.d/ftp could probably solve this problem?

Kind regards,


Hi arusa

Many thanks, good idea

Please could I ask if you have debug set to on, if so, if you disable debug output does this then reduce the entries

Many thanks


Thanks, you are right, SysLogLevel “debug” was enabled and I changed it to “info”.