ProFTPD - Secure (FTPS) by default

After discussing similar stuff on another thread I think it would be a good idea to have ProFTPD as a FTPS server by default. I have it setup on my server following Chris’s instructions here (

It works great and I have it just on port 21 for both secure and non-secure.

So I think this could be implemented so the people that want to use it have it and it won’t affect those that don’t need or want to use it.

We’ll be distributing proftpd with FTPS ‘on’ and we’ll have an option in the interface as well to turn on/off FTPs Justec. We won’t have it replace the default FTP but we will allow turn it on/off from the interface.


Sounds good.

Funny that I just posted that and today my ProFTPD no longer has Mod_TLS. I didn’t change anything. I dont see any updates under NodeWorx that may have overwritten it.

The only thing I did was reboot the server.
Any ideas?

Does “proftpd -l” still show it? And no, we’ve released no proftpd updates that would have killed it. The next proftpd update we do will include the mod as well so you should be fine.


Compiled-in modules:

I don’t see it under here anymore. This happen one time before without reboot, but I think it was because YUM “updated” it becasue it was different than the default Iworx ProFTPD. Last time I just had to recompile (rpm) it and that fixed it. This time there was no update I could see under NodeWorx and the only thing I did differently was reboot my server. I have not re-setup the mod_tls yet.

When is this expected to happen? I was just about to try to follow Justec’s instructions on my server and set up SSL, but I guess if it’s coming up in the near future and it’ll be THAT easy, i should just wait/save myself the hassle?

It will be after the 2.0 release int, so if you’re looking to get this going soon I’d go ahead and do it per Justec’s directions.



Well I tried - the compiling steps both worked fine - it’s the SSL i’m having issues with.

I assume the SSL certificates have to be bound to a different IP?

Well either way, the fact is I don’t see SSL in Nodeworx OR Siteworx anywhere - except the “Generate Key” under Server Setup in Nodeworx, which is the Interworx API Key (and as far as i’m concerned, not what i’m looking for)?

I will post another thing to try in the original forum (top of this thread) on the setup of SFTP w/ ProFTPD.

Chris, I think the problem may have had to do with an old RPM file.

I had both of these files under:



In your orignal instruction in the other thread you specified the RPM did not have the rht90 in the file name. I deleted both of these RPM files and recompiled ProFTP as per your instructions. But on the “force” line I reference the .rht90 rpm and the other one isn’t there anymore.

Any words on this being included?

I am trying to do the same thing from Source RPM for CentOS4 x64 but it keeps failing.

error: Bad exit status from /var/tmp/rpm-tmp.73124 (%build)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.73124 (%build)

This is what I ran to produce the above error:
rpmbuild --rebuild --with cnt4064 --with mod_tls


I get this when i run the command:

RPM RELEASE: 101.iworx
OS TYPE IS : Unknown Distribution
GCC IS     : gcc
CCFLAGS    : -O2 -g -pipe -m64
LDFLAGS    : -O2 -g -pipe -m64


Try the --with rhe4x I posted in the other thread Justin.


Any update on this?