Qmail 451 mail server temporarily rejected message (#4.3.0)


I posted this in an old thread but was not sure if it is active anymore!
I am getting an error every time a message is sent to a domain on the Interworx box. I have tried with My clamav service is running and not. Everything that gets sent to this server is rejected with this responce being sent to the sending server- 451 mail server temporarily rejected message (#4.3.0)
as well as this line after the following line- 1 1104 00:00:00 ERROR OXU03130
I have searched and have found nothing that will fix this problem. It can send find and any message that is sent to another domain on the same server is recieved fine. But anything that comes from the outside is rejected with this message.

Any help would be greatly appreciated!!!
I have reinstalled simscan restarted qmail tried with an without spam turned on. The firewall is open.

A side not does anyone know of a good list server that works well with Interworks.
I would like to add that I am very impressed with the responce I have gotten when I needed help. This is one of the reasons I was trying to find another salution to the email software I was using. I paid for support but it was almost impossible to get a responce and when it did come it was always wait until the next release to get a function that I had already paid for. You may not have all the features right now but I would rather have your support over there features that half the time don’t work anyway.


Hello again,
I tried sending an email using outlook with an account on the server and I get this error when it tries to send - qmail 451 unable to exec qq (#4.3.0)
I can not connect to the pop3 server as well.

Any help at this point would be great


Hi Tantons,

If you pay for support then open a ticket for it. The response of the Interworx team is always fast and they sure will help you.
Goto: https://www.interworx.com/support/helpdesk/ to create a ticket.

If it’s not a case of ClamAV being down which it sounds like it’s not, we would have to login to the box and check it out, so rone’s suggestion of opening a support ticket is probably best.


Sorry I didn’t mean their support!!! It was support from another software cmpany I was speaking of! Interworx support has been very good!!!


Did you resolve the problem ?


Hey Pascal, I sent a support ticket. there are looking at it now. I didn’t see that you had replyed until now!

As I don’t have alot of knowledge about Linux, I don’t want to send a support ticket every time I have a problem. As the problem might be me. I want to rule that out first. jajaja


This issue appeared in the last few hours for us. Not even our dedicated Spam Appliance was able to pass mail through, and its deferred queue stacked up.

We disabled the ClamAV/Anti-Spam on the (Iworx) server and flushed the defferred queue on our Spam appliance and all mails came through. We are investigating what is/has caused this.

This issue appeared too this night !

Only for one old server (not the cluster one) !

delivery 204: deferral: xx.110.xx.145_failed_after_I_sent_the_message./Remote_host_said:451_mail_server_temporarily_rejected_message(#4.3.0)/

The best should to open a ticket !


The clamd seems to be the problem !

In /var/log/smtp/current I see a lot of simscan clamd error

Also if I look a the clamav page on nodeworx, the virus definitions file seems to be empty

main.cvd 31 Dec 2006 13

Yes you are right Pascal. I’ll be submitting a ticket in a bit - or maybe Iworx can respond here for everyone’s benefit :slight_smile:

In fact it has been some soft updates

  1.  clamav.x86_64  	 0:0.90-100.rhe4x  	 os  	

2. perl-Mail-SPF-Query.x86_64 0:1.999.1-101.rhe4x os
3. perl-Net-CIDR-Lite.x86_64 0:0.20-101.rhe4x os
4. perl-Sys-Hostname-Long.x86_64 0:1.4-101.rhe4x os
5. proftpd.x86_64 0:1.3.0a-104.rhe4x os
6. spamassassin.x86_64 0:3.1.8-200.rhe4x os

I have opened a support ticket !

What is that as soon as there is a


There is these logs


ClamAV update process started at Sat Feb 24 17:15:15 2007
main.cvd is up to date (version: 42, sigs: 83951, f-level: 10, builder: tkojm)
Downloading daily-2642.cdiff [100%]
daily.cvd updated (version: 2642, sigs: 10362, f-level: 13, builder: ccordes)
Database updated (94313 signatures) from database.clamav.net (IP:
Clamd successfully notified about the update.

Then all definitions disepears


Hi guys,

CentOS released an update to SpamAssassin recently, and we upgraded our packages to match. We’re aware of the current situation, and are looking in to it. We’ll have an update for everyone shortly.


Thanks Socheat

And good luck


Fedora 3 & 4 here Socheat, unless its a sweeping package and distro doesn’t make any difference.

Thanks for the update - most appreciated :slight_smile:

Hi guys,

Apparnetly something changed in the new ClamAV version that was resulting in clamav not being able to read the directory’s owned by the simscan user, even though it clearly should, and has in previous versions.

yum update

on your boxes, that will pull down a newly updated simscan RPM that should work around the new clamav behavior.


The problem is resolved !

Interworx has done a new version of simscan, which will be automaticly installed if you have the software updates set to ON !

Thanks a ton to them


Arff sorry guys

I still was at the end of the 1st page !

I started having this problem again! Clamav won’t even start, and every message sent to the server is rejected! what changed between last weekend and this weekend? was there another update?