Quotas not updating correctly


All the quotas for my users are set to “0” of disk usage, how can I fix this?

I tried http://www.interworx.com/support/docs/iworx-cp/sysadmin/backup-restore/faq#quota_problem and this did not fix the problem.


What do you see when you run the following command, as root:

repquota -g /home (or whatever partition your /home directory is mounted on)

Do you see any values (other than 0) under the Block Limits (soft or hard) columns? What happens when you do:

quota -g username

Where username is the 8-character username of one of your SiteWorx accounts?


[root]# repquota -g /home
repquota: Mountpoint (or device) /chroot/home not found.
repquota: Not all specified mountpoints are using quota.

Disk quotas for group xxx (gid 503):
Filesystem blocks quota limit grace files quota limit grace
/dev/vzfs 39277 4194304 4194304 3166 0 0

Which of the quotacheck commands did you run? You should be running:

quotacheck -cugvmf -F vfsv0 /

And afterwards, run the storage.pex command. If that still didn’t fix the problem, open a ticket, and we’ll check it out.


I ran:

quotacheck -cugvmf -F vfsv0 /

Did you get any errors? At this point, it’d be easiest for you to open a ticket with your root login information and NodeWorx login information, and we’ll check it out.


No errors what I can see. I did run this command earlier and it worked - but it didn’t work this time around.

Is there something I should do with the owner/group permissions? I’ve got a faint memory of doing something like that in the past.

So, any ideas what I can do - on my own so to speak? (This way I’ll be able to fix this problem on my own if it occurs again)


Is this a Virtuozzo VPS? Perhaps the quotaugidlimit needs to be set for your VPS. From the Master VPS:

vzctl set <VPS_ID> --quotaugidlimit 1024 --save

Where <VPS_ID> is the ID of your VPS. You can change 1024 to a higher number if you choose. The VPS will then need to be restarted.

Also, look in /home/interworx/iworx.ini and look for the line beginning with:


On your box. it should be:


If it’s not, set it to /, and then re-run the storage.pex command as root:

If that still doesn’t work, please open a ticket, and we’ll take a look. We’ll definitely let you know what was wrong so you can fix it on your own if it happens again. :slight_smile:


Can I go into the Master VPS as a indivdual VPS-customer, or must my tech-rep at the datacenter do this for me?

The partition value is correct now already :slight_smile:

You will need to have your tech-rep at your data center do this for you.

I will open a ticket with them now and refer them to this thread.

I got the following response from my data center tech-rep:

“Quotas appear to be working properly, but there don’t appear to be any set for any of your users. Please try to modify each siteworx account and set or reset the quota setting to reset the quotas.”

How can I fix this, with a scripted command similar to what is in your FAQ and what I posted in my initial post here?! (I am not too keen to go into every user’s account in SiteWorx and resetting this manually if there is an error of this kind)

Issue is now resolved thanks to Socheat and Kevin at Steadfast :slight_smile: