Roundcube 90second mail send limit

Got a small problem with interworx roundcube settings.
This is old problem for me that after every interworx version update i need to go interworx settings (/usr/local/interworx/lib/roundcube/config/ and change this config line: $config[‘sendmail_delay’] = 90; to 10 because 90seconds mail send interval is to high.
I change this to 10sec but after every interworx update it’s overrided.

Any good ideas how to avoid this every update override thing?

At a glance, the typical setting is 0. Possibly we increased in our conf to combat compromised email accounts spamming via Roundcube. However, I’m not finding a record of this, so maybe 90sec is an old default for the file.

I will research further and discuss it with the team, then decide if we should change to 0 or 10 and look at making this configurable in the UI.

This information is wrong, typical setting is not 0 because after every interworx version update it’s back to 90.
If You say default is 0 then why it changes back every time and how i can solve this permanently?


@vmk iWork-Joseph post states he will pass by devs and to ask if setting could be made changeable from UI in nodeworx.

This would make it permanent even after an update

Please be patient

Many thanks


No problem to wait more because problem is over year old and last time contacted IW support over one year ago still nothing (this is reason why i started discussion here).

Also i think that 0 is not perfect and 10sec or something like that is reasonable against spamming…

Sorry, I worded that badly. I researched and found that most 3rd party confs go for a setting of 0 and I was going to look into making that our default.

Turns out there is a way to add this setting to the new template system on Interworx 7. Are you on 7?

Still on 6.* because 7 shows still beta “badge” and not very interested beta versions…

But updated few moments ago to 7.*

I have updated our default sendmail_delay for 6 and 7 to 0. It should make its way into our beta build next week and into GA sometime in the next month.

Fantastic, thanks…i test this later :slight_smile:

Also updated to 7…seems like everything is working fine.

I’ll post on updating the Roundcube conf template anyway. It could be handy for others who find this topic.

Did you set the update channel back to release (default) after updating to beta?

Tryed but back to release is not possible, changes back to beta if You refresh page.


I could be wrong sorry but it was always my believe that once you set to beta channel and update to beta. You cannot go back to stable or RC

I know beta has been talked about on forums over many years periodically

As I said, sorry if I’m wrong

Many thanks


It seems You are correct, for me this is new problem now what needs solution.

You should be able to go back to release. I’ve done a few upgrades to Beta and then set release and it was working fine then. This sounds like a bug. Could you open a ticket with RA set up so we can take a look. I’m going to try to reproduce on a test server in the meantime.

It is pretty common to need a new feature that is in beta and then go back to release. It does not uninstall anything it just means you stay on the current version until Release catch’s up.

@vmk Looks like the beta channel is getting disabled. It’s just not showing in the UI. Looking into this still. To double check take a look at /etc/yum.repos.d/interworx-7.repo

You should only see [interworx-7-base] and [interworx-7-ga] enabled, presuming you enabled release only.


@vmk I was able to reproduce and pretty much got my head wrapped around the issue. It’s definitely a bug. I guess no need to open a ticket at this point.

As per my last reply, beta is disabled correctly. It’s just the UI, CLI, and API that report back incorrectly that it is still enabled.