RoundCube password plugin

I’m setting up a RoundCube instance for one of my domains, and I would like to add the password plugin ( It supports several different protocols for changing passwords, but I don’t see an obvious reference for how InterWorx handles this. Can anyone provide assistance?

Are you not using the Interworx provided version at ?

No, this is a custom install due to the level of customization and branding required by the user.

Probably you have to use ‘vpopmaild’ as the password driver as iworx uses vpopmail.

222	// vpopmaild Driver options
223	// -----------------------
224	// The host which changes the password
225	$rcmail_config['password_vpopmaild_host'] = 'localhost';
227	// TCP port used for vpopmaild connections
228	$rcmail_config['password_vpopmaild_port'] = 89;

I have had success with cpanel driver on a cpanel shared host (of course, the built-in cpanel.php file didn’t work; I had to replace it with one downloaded from roundcube forum, the latter also doesn’t require cpanel username & password to be entered in the config file, they are not needed.

231	// cPanel Driver options
232	// --------------------------
233	// The cPanel Host name
234	$rcmail_config['password_cpanel_host'] = 'server.myhost.tld';
236	// The cPanel admin username
237	$rcmail_config['password_cpanel_username'] = 'I didn't give this';
239	// The cPanel admin password
240	$rcmail_config['password_cpanel_password'] = 'Say no for this too :) ';
242	// The cPanel port to use
243	$rcmail_config['password_cpanel_port'] = 2096;//webmail port (nonssl 2095)
245	// Using ssl for cPanel connections?
246	$rcmail_config['password_cpanel_ssl'] = true; // my host uses ssl
248	// The cPanel theme in use
249	$rcmail_config['password_cpanel_theme'] = 'rvskin'; // my host uses rvskin

Really? As far as I can tell vpopmaild isn’t running on my system…

I am not sure about the daemon name (i.e it may not be called as vpopmaild) but what I know (up to my knowledge) is IWorx uses vpopmail (as I remember iworx crew suggesting to use vdeldomain for the domain’s mail to be taken care of elsewhere, i.e no mail accounts on the iworx server; so iworx uses vpopmail, but not sure of its daemon’s name)

IWorx-Paul said “we’ve provided a password plugin for roundcube for quite a while now” on thread

He knows more about it, but speaks on the forums very rarely these days ( I guess :slight_smile: ).

Have you tried setting “vpopmaild” as the driver in roundcube config?

PS: if you have your license directly from iworx people, I think you may open a support ticket regarding the roundcube password plugin.

I have tried the vpopmaild driver, but it returns a failure. I will open a ticket and see if they can provide assistance.

Did you update the driver using software? I would be interested to hear what worked for you?