rTorrent

Does anyone know an easy YUM or RPM install for this on Cent OS 4.4 64bit?

I remember there was some kind of CentOS YUM repo for CentOS that was like for non-default packages. Think it was called CentOSplus and it contains stuff like PHP 5. Maybe its in there?

Any ideas besides compiling it myself?

Doesn’t look to be in CentOSPlus or in the extras repositories. However, it is here:

http://dag.wieers.com/packages/rtorrent/

Speaking of the CentOSPlus repo, that reminds me… :slight_smile:

Thanks Socheat, I was just reading through the manual install and it seems very easy (if the configure file worked right), but I like the RPM method b/c then I can uninstall it. If I did the install manually, it would copy all the compiled files to /usr/local (/bin, /man, etc…) and I dont know any easy way of removing them if I wanted to in the future.

I assume the RHEL4 64 bit is the one I need correct?

rtorrent-0.5.3-1.el4.rf.x86_64.rpm	Mon 16 Oct 2006	297 kB	Red Hat EL 4 - x86_64

Uh oh, what are you up to :stuck_out_tongue:

Thanks again!

Actually that RPM is an older version, the current verison os 0.6.3.

I’ll probably just try the ./configure; make; make install. There is a way to install everything to its own directory instead of /usr/local so I can just stick it in its own folder.

Indeed; that’s what the

--prefix=/your/funky/folder/structure

option is for :smiley:

Well I just tried running ./configure to see what it came up with.

I got this error:

No package 'sigc++-2.0' found
configure: error: Package requirements (sigc++-2.0 libtorrent >= 0.10.1) were not met:

I found RPMs for both of these on the DAG site:

[[email protected] rtorrent-test]# rpm -qa | grep sigc*
libsigc++20-2.0.17-1.el4.rf

[[email protected] rtorrent-test]# rpm -qa | grep libtor*
libtorrent-0.9.0-1.el4.rf
libtool-libs-1.5.6-4.EL4.1.c4.4
libtool-1.5.6-4.EL4.1.c4.4

But I guess since the RPM for the libtorrent is .9 it wont work. So I am just going to install the old RPM version of rtorrent that Socheat found for me. I mean its old version but the date on the DAG site is from this Monday, so it can’t be that old.

Well I let my inner nerd out and decided to compile it.

So i download the source for the 3 packages (sigc+±2.0, libtorrent, rtorrent).
I put them all to a subdirectory of a home account so then I did an export library path to that directory. I also did configure on that directory as a prefix.

Then i had to set some pkgconfig env var to point to the path where the .pc files were. Once I figured that out all went pretty smooth. Except I thought I install the libtorrent, but it didn’t seem to be there. Then I did it a 2nd time and there it was.

Then I just set the PATH to the directory of the bin where rtorrent is and that was that :smiley:

Not that I have ever used a torrent file or would know what todo with one, you should check out:

http://www.torrentflux.com/

Very slick.

I personally need a VPN for torrenting with unlimited bandwidth https://www.seedboxco.net/ I am torrenting movies and would like to do it faster. Can anyone here help?

Hey, I used to site seedr.cc for download torrent file free use can download ulto 4 GB and if he refers then he can gain more storage. seedr give you direct link download any file no software required