Server & DNS setup, Qmail aliases, SMTP DNS failure errors

I’d sure like to know what I’m doing wrong…

When a domain becomes a host name for a Nodeworx server (VPS in my case), must the domain be a Siteworx account? I’m not interested in hosting a site for the server domain or in using real mailboxes on the server. I’m trying to use only a host name and DNS. What’s the right way to do this?

Here’s what makes sense to me:

In DNS Management I added a zone for the server’s domain, gave it an IP, 8 records were created.

I added an A record for each name server which corrected a red spot during DNSreport testing.

The remaining DNSreport failure is the postmaster alias. DNSreport is trying to connect to but can’t. Qmail alias files exist and appear correct.

If the server is setup as a Siteworx account – as opposed to having only a zone, the same set of 8 records are created and the host name resolves. Plus a mailbox account for postmaster is created which corrects the DNSreport failure. DNS issues at least appear to be ironed out at this point but they’re not.

Using this server-as-site setup, when sending mail from a remote desktop client like OE or TB I get SMTP error 451 DNS Temporary Failure. Mail sent from Squirrelmail works fine. I never tried sending from OE or TB while the server was setup the first way but web clients worked fine. Both spamd and clamav are working when enabled but I keep them off while trouble shooting. I don’t enable spamd for SMTP.

I’m not fixated on the postmaster alias (other than wanting it and other alias transport working). I just contend that if the postmaster alias fails a basic test, something fundamental is wrong with the MTA and how the host name resolves.

Many things happen, behind the scenes, when you create a SiteWorx account (let’s say ‘’). Here are a few things (not in any particular order):

1.) DNS entries are added for ‘
2.) a system user (domainco) is created for the SiteWorx account.
3.) a home directory is created for user (/home/domainco/)
4.) server is told to handle mail for this domain, and postmaster account is created. This means vadddomain and vadduser are called, to tell the server “you are the mail server for this domain, and add the postmaster email account for that domain”

At this point, the server knows it’s the mail server ‘’. When you send mail directly from the server (using webmail for example) to, say,, qmail sees ‘’ and realizes “I’m the mail server for this domain, so I’m going to do local delivery”. So, the email never makes it out on the net, and gets delivered to the local inbox (/home/domainco/var/

If, at this point, you want mail hosted elsewhere off this server, you will need to tell the server that it is not the mail server for this domain. You do this by running, as root:


Now, when you send mail directly from the server (again, say using webmail), the server sees that it is not the mail server for, so it does an MX lookup for ‘’ and delivers accordingly.

The other scenario, when you simply create the DNS records accordingly, you are essentially manually performing step 1, and skipping all the other steps. This means you also skip step 4, where you tell the server that it should be managing mail for ‘’ and the postmaster account does not get created.

As for your temporary DNS failure message, can you check that all you have in/etc/resolv.conf is “nameserver”?


So essentially, there will be missing components or bad UIDs without Siteworx handling the server domain. Whatever works best is what I want.

I thought the aliases in qmail/alias took the place of an account.

resolv.conf contains a search line and two nameserver lines for the data center. Replace this with the localhost IP? Would it help to add a localhost A record?


Leave the datacenter lines, but add the localhost one above them all.

Hope this helps :slight_smile:

Thank you but adding ‘nameserver’ to resolv.conf did not fix the SMTP problem. With a new account on a new site, SM sends but remote clients still can’t send. Same error:

Server Response: '451 DNS temporary failure (#4.3.0)

The server is no longer site-less and its DNS came from creating a Siteworx account.

Still stuck.

My memory is failing me sysnop, but I’m sure if you open a support ticket with your login information so we can poke around, we’ll figure out what the problem is.