Setting default webmail client

We just upgraded to 4.3 from 3.x, and we are really pleased with the new webmail client: RoundCube. We have always been embarrassed with our webmail offering, as many of our clients are accustomed to webmail such as Gmail and Yahoo Mail, but RoundCube really looks nice.

Question: How do we make it the default? The choices appear to be alphabetical, and turning off Horde is not an option because some users do not like change.

Hmm…It’s actually not an option currently…but certainly easy enough to implement. I’ll log a feature request for the next non-maintenance release.

BTW, just so you know - RoundCube puts more of a load on the host server than the other webmail clients. It honestly might be because it’s nicer, so people actually USE it :slight_smile:

Tim, based on the “Nice Factor” as mentioned above of RoundCube. How about a fourth choice of Webmail clients. And that would be AtMail, open source version more details located here www.atmail.org which is basically a stripped down version of the paid version www.atmail.com

I personally really like RoundCube, but if I had a choice of the two I would use AtMail.

That’s cool - last I looked, there wasn’t a free version…we’ll have to consider any potential licensing issues, of course, but it’s worth looking into.

BTW, the “default webmail” feature will be in InterWorx 4.4, whenever that makes it out the door.

Yeah the version at www.atmail.org is the free AND open source version.
And yes, consideration for licenses would be needed.

Here is part of what the www.atmail.org site has to say:

  • AtMail is an open source webmail client written in PHP. We aim to provide a elegant Ajax webmail client for existing IMAP mailservers, with less bloat and a focus on an intuitive, simple user interface.
  • The open source version of AtMail provides users with a lightweight, yet powerful webmail client. The software can be installed on a variety of platforms with ease and without the hassles that most webmail platforms impart.

I 2nd R-n-R on using Atmail Open (the open source version of Atmail). It uses the Apache 2.0 license (per their website).

Thank you!

And thanks for the tip about Roundcube and server load. We’ll keep an eye on it, but we are seeing any measurable difference so far.

The real issue is that RoundCube seems to cause higher MySQL connection counts than Horde or SquirrelMail. This has nothing to do with Roundcube, they’re not “doing it wrong” or anything, but because it uses AJAX to check mail, it makes connections to the server even when the client isn’t viewing the page, whereas the others just sit there until someone hits refresh.

It’s one of those things that’s completely fine - until it’s not. Then everyone starts getting “cannot connect to mysql - too many connections” and you’re sad :frowning:

It’s partially a config thing - the mail clients connect to the InterWorx database, not the client database, and our configuration is intended to leave as small a footprint as possible. With tons of clients that all use webmail at the same time, the configuration is just too small. It’s an easy fix, we can just scale up the configuration to be a better fit when it happens.

With MySQL in mind, does anyone know the theoretical limit for MySQL connections on a CentOS server? Or is that just a hardware limitation issue?

Up to version 5.1.17, the maximum value was 16,384. Since 5.1.17, the value was increased to 100,000, which is a really weird number (not binary).

http://dev.mysql.com/doc/refman/5.1/en/server-system-variables.html#sysvar_max_connections

I’m guessing that most servers would hit the hardware limit before that, though.

[QUOTE=IWorx-Tim-Pgh;17024]The real issue is that RoundCube seems to cause higher MySQL connection counts than Horde or SquirrelMail. This has nothing to do with Roundcube, they’re not “doing it wrong” or anything, but because it uses AJAX to check mail, it makes connections to the server even when the client isn’t viewing the page, whereas the others just sit there until someone hits refresh.

It’s one of those things that’s completely fine - until it’s not. Then everyone starts getting “cannot connect to mysql - too many connections” and you’re sad :frowning:

It’s partially a config thing - the mail clients connect to the InterWorx database, not the client database, and our configuration is intended to leave as small a footprint as possible. With tons of clients that all use webmail at the same time, the configuration is just too small. It’s an easy fix, we can just scale up the configuration to be a better fit when it happens.[/QUOTE]
Thanks for all the very helpful information! Should the problem arise, do I just need to increase some limits in /usr/local/interworx/etc/my.cnf and restart iworx?

Yup. The default max_connections is 8, I think - we usually jump to 32 as the next step and monitor from there.

[QUOTE=jimp;17001]…We have always been embarrassed with our webmail offering, as many of our clients are accustomed to webmail such as Gmail and Yahoo Mail, but RoundCube really looks nice.
[/QUOTE]Squirrelmail doesn’t try to be sexy, that’s what makes it so sexy. :wink: Roundcube is definitely a slick webmail app so it goes well with Interworx.

Maybe somebody in this thread can answer one of my webmail questions:
http://interworx.com/forums/showthread.php?t=3169

[QUOTE=IWorx-Tim-Pgh;17012]
BTW, the “default webmail” feature will be in InterWorx 4.4, whenever that makes it out the door.[/QUOTE]

Hi,
Where should i find this option?
Thanks
G

Server => Settings => Webmail Options => Default Webmail Client

I am trying to set this value now (finally need the bump). The MySQL documentation says 151 is the default. Is 8 somehow passed at invocation, or if I set max_connections in my.cnf will it still apply? How can I verify the runtime config?