Sharing Databases between SW accounts

Here’s my situation:

I’m installing Drams Plus on my server in the domain

Drams wants both a secure and not secure domain so I created a second sw account

on it’s own IP – since I will probably install an SSL certificate – but when I try to log in it, I get

Unable to select database

The files are itentical in each sw account including the page that has the database info. Is there a possible workaround for this? I really don’t want to create an identical database (which wouldn’t be identical for long) on the second SW account. Right now I can’t even log into it because it points to the secure url for both “login” and “new account.”

In the short term I could just update my drams liscence to use the same domain as the non secure one but that would not really solve the problem.

Moving the whole thing to the dedicated IP could also be problematic since Mailman is installed on this domain in the subdirectory.

Any help or advice would – as usual – be appreciated.


PS I’m also getting the Invalid Liscence error again. I put in a support ticket.

I noticed something else. is a blank page

the files in this are copied from the first with the cp command. When I uploaded them inthe first place I had to do so in binary to keep them from being corrupted. Could cp -R have corrupted them when I did this?

Would cp -A have been better? What about tar?

cp -A is invalid but I redid the copy with the following command:

tar lcf - .|(cd /home/mytransw/; tar xpvf - )

modified from the command Chris gave me to mirror my hard drive pre-migration and it looks like it worked.

crosses fingers

It works other than I am having a problem accessing a page with https:// (other than InterWorx). Chris is going to look at it later.

The liscence thing is fixed thanks to instructions from Chris.

I get the apache default page when I try the Tim, was this the prob you were reporting or was it a “blank page” as you stated before.


Also, cp -R was fine Tim, it does a verbatim copy.


That’s what I get when I access from Mozilla (IE takes me to to PerfectNav a search engine thing that installed itself with Kazaaa and does this when the host can’t be found.

This problem ONLY exists with https:// not with http://

Realy? When I loaded (secure) I got the problem above. When I tried (not secure) I got a blank white page.

When I did the copy with tar it fixed the blank page problem. Just one of those things, I guess.

I should say here for anyone reading this that DramsPlus uses Ion Cube to encrypt some of the files and warns us that we have to upliad the files in BINARY (as opposed to ASCII which you would normally do a page with).

When I go to and click in Create Account or Login, I get the following message:


You have recieved an invalid certificate. Please contact the server administrator or email corispondent and give them the following information:

Your certificate contains the same serial number as another certificate issued by the certificateauthority. Please get a new certificate containong a unuque serial number.

both of these are “secure” links.

Could this be related to the problem we fixed yesterday?

On a hunch I logged into SiteWorx and created a self signed certificate for this domnain. Then I went out and tried it again and low and behold it works now. Don’t ask me why. You don’t have to have a certificate to load a secure page, do you?

At least to use https you need to have a virtualhost block that listens on the https port, 443. Setting up a self-signed cert would take care of this for you, so that may explain why it started working at that time.

This thread started as a question re: databases, did that part of the question ever get answered? If not, can you explain that problem once again?

I thought it must be something like that :slight_smile:

This thread started as a question re: databases, did that part of the question ever get answered? If not, can you explain that problem once again?

When I started this thread I thought I was having problems accessing a database set up in one site worx account by another site worx account. This appears to be a non issue as it works now.

I have a mirror of the same files in both domains/SiteWorx accounts, but the database is only in the one but it does not seem to be a problem. Both domains can call the same database. That’s great!

The way I have this set up is going to present a problem, however. Drams is not COMPLETELY database configured from what I can tell, so I will need to edit some files by hand. To configure this I will need to re-mirror the files every time I make a change :frowning:

I thought about just moving them to the same domain and changing my Drams liscence to call (regular) and (secure) and ditch the “my” all together but the main domain is on a shared IP with over 30 other domains and to do this I would need to move it; to top it all off I have mailman on the same domain/ip and I don’t want to edit the files (the only way I know how to move a domain from one IP to another) by hand for fear of screwing that up (not that I’m entirely sure how to do it anyway).

Does anyone have any other ideas?

Other than that I like DramsPlus a lot and am anxious to see how it will integrate with InterWorx 1.8.1 when it comes out. If I understand what I am seeing (in the Drams interface) it won’t just import my packages from NodeWorx, I will have to re-create them in the Drams interface (a minor, but anoying glitch).


Just to update you as to how I got around this:

I updated my drams liscence to use the following domains (non secure) (secure)

I had to contact Dram Systems and have them update my liscence and download and install a new liscence key. I also had to edit a couple things in the database in question through the MySQLMyAdmin and make a change to the config file because it led to the original location of DramsPlus on my server.

Then I put a http redirect file at leading to