Siteworx account won't import - no IPs available

I need to import a Siteworx account that was previously hosted on a shared IP. I need to restore the account onto my server’s shared IP just like before. The problem is that I gave this site either a self-signed or LetsEncrypt SSL certificate and now the backup can’t be restored because no IPs are available. I’m assuming this is because Nodeworx expects a dedicated IP for this import.

Is there an easy way around this that doesn’t involve manually stripping the SSL certificate and re-packing the backup?

Re-creating the site from scratch wouldn’t be so bad in this case but importing would be so much easier.

Thanks in advance for suggestions.

Hi sysnop

I’ll have to think about this one, but if needed ASAP I’d open a support ticket

There are 2 thoughts that come to mind

Have you tried setting an internal IP (does not matter what it is) in interworx, then try importing you backup and give it this internal IP address - if works, you can reassign to shared

Have you tried mass import but select only that siteworx account - subject to server been online

I thought the SSL had been overcome but not sure over LE importing

Last one, is there are subdomains, or secondary sites setup on the siteworx - just a though

Many thanks


Hi John,

Not an emergency so I’ve got time to figure it out but thanks for offering support.

There are no sub-domains or secondary domains.

I haven’t tried any of the possibilities you mentioned but I like your suggestion of adding an IP like 192.x.x.x. Which got me thinking… I have a v6 IP not in use – I’ll just try that one! I will post my results later today.


A 192 address worked like a charm.

Brilliant! and thanks again.