SiteWorx Rails Error

Hello, I have installed ruby, rails, rake etc …
And I’ve configured everything according to documentation of InterWrox.
When I try to create a Rails application in SiteWorx, I get this error:

A system error has occurred. Please try your request again in a few minutes.
If the error persists, please contact support.

Any solution?
I need to make it work.


Hi rtj20

I hope you don’t mind as I don’t use ruby, but you have not given a lot information.

Have you checked your logs for more

Also, it would be helpful to the forum to know your os and interworx version used, and if on vps or dedicated.

My initial thoughts are perhaps it not configured correctly, but have you tried a simple test to confirm if your controllers etc are working, or was this the test app you were trying.

If you need a quicker resolution, I would open a support ticket with interworx, or be patient if just using the forum, there are a lot of experienced uses on here, who may help.

I hope you don’t mind my thoughts.

Many thanks


All I can see in the error log is as follows:

[EMERG] : ERROR: /usr/local/interworx/include/IWorxFileSys.php(205):
----- ASSERTION FAILED BEGIN ----- : rails.php
[EMERG] : ASSERTION FAILED: /usr/local/interworx/include/IWorxFileSys.php (205): : rails.php2014-02-08
[EMERG] : ----- ASSERTION FAILED END ----- : rails.php
[EMERG] : ----- DEBUG STACKTRACE BEGIN ----- : rails.php
[EMERG] : /usr/local/interworx/include/IWorxDebug.php getStackTrace (167) : rails.php
[EMERG] : /usr/local/interworx/include/IWorxDebug.php errorHandler (87) : rails.php
[EMERG] : /usr/local/interworx/include/IWorxFileSys.php debug_assert (205) : rails.php
[EMERG] : /usr/local/interworx/include/CLI/Rails.php chmodRecursiveDirectories (104) : rails.php
[EMERG] : /usr/local/interworx/include/CLI.php _create (169) : rails.php
[EMERG] : /usr/local/interworx/include/CLI.php _execRun (140) : rails.php
[EMERG] : /usr/local/interworx/bin/rails.php run (34) : rails.php
[EMERG] : ----- DEBUG STACKTRACE END ----- : rails.php

Any idea what it could be?
I’m trying InterWorx, if I can solve the problem definitely be my Favorite panel control.

It works with manual isntallation.
I have this problems only if try startapp with siteworx.

Hi rtj20

It sounds like a permission based issue, but as I said, I don’t use ruby sorry.

Have you tried setting php to siteworx and not apache, nodeworx service setting, web server, php uses siteworx

I hope that helps a little and I’m sorry if I am wrong

Many thanks