Spamassasin Control via siteworx

There is a bug in the siteworx spamassasin options. Having selected spamassasin to “off” in the siteworx control panel, incoming mail for the associated domains is still being scanned by spamassasin.

Hi Alan

This is not a bug I believe.

You can have SA check on siteworx account whilst other siteworx or mail server set to off

Do you mind me asking if you just want it turned off or if you mean checking on incoming smtp

Many thanks


Sorry, a thought after rereading.

By associated domains, do you mean sub domains. If so, you need to access these subdomains and turn SA off.

When logged into siteworx account, top you’ll see managing domain, you can change to sub domains here from the drop down box

Many thanks


Hi John,

The current setup is this.

Nodeworx, spamassasin is set to on.

In one of my siteworx account, I’ve set spamassasin to"off".

My assumption is that for the siteworx account that I’ve disabled spamassasin for, incoming mail for that account should not be scanned by spamassasin?

Currently with the above setup, spamassasin still scans mail for siteworx account in question.

Hi Alan

Many thanks, it’s clearer now

You have just turned off the siteworx admin SA level. Not the server SA level I believe.

I think this is correct and why mail is still be scanned at higher level

You can goto MTA I think and turn it off but it will stop all high level scanning for all mail

Sorry if I’m wrong

Many thanks