Spamassasin script / module mismatch

Noticed the other day that Spamassassin wasn’t running, can’t start it via the control panel, so attempted to start it via command line, which generates the following error:

service spamassassin start
Starting spamd: Jul 23 06:42:53.109 [5617] error: spamd: spamd script is v3.003001, but using modules v3.004000
spamd: spamd script is v3.003001, but using modules v3.004000

It seems the modules have updated to 3.4.0 but the script is 3.3.0. I’ve tried removing the 3.4.0 modules from /var/lib/spamassassin but that hasn’t cured it. I’m assuming that somewhere there is a config file which points to relevant lib directory?

Anybody know where it is and how to fix this issue?

Any help appreciated.


Hi Alan

I hope you don’t mind, but there’s 2 things which come to mind quickly, both I’m sure you have tried, but here goes

Cannot you do yum downgrade or have you looked on IW repo for grabbing the SA and installing it again. You should see this folder from support I think but I’m not in front of a computer sorry.

I’m sorry if I’m wrong though, and I’ll think about it a little more

Many thanks


Hi John,

Thanks for the suggestions. I had tried the yum downgrade, but that didn’t fix it.

I hadn’t considered pulling the SA from the IW repo and forcing an upgrade - that worked and is working again now