SSL Certificate Option

Hi,

Question, I have 12 domain being hosted within my Interworx CP. Why would only some of them, when accessing Siteworx, offer the SSL option under the Domains option. Some of the domains being hosted have DNS Records and SSL not present when I expand the Domains option under hosting features. Why is this?

Thanks
Lance

Hi hostpanda

I hope your well

If you log into nodeworx, siteworx, edit the siteworx domain(s) which do not have SSL option, and enable SSL for the siteworx, save and this will turn on the option for SSL in the siteworx account.

I hope that helps

Many thanks

John

Great, thank you.

Next question: I just installed a new SSL multi domain certificate with SAN support for 4 of my hosted domains. My primary domain is hostpanda.net and can be reached at https://hostpanda.net. I am also hosting other sites including garvers.us. After installing this new SSL, when I travel to https://garvers.us or any of the other 3 sites that are included with this new SAN SSL, they all redirect back to the main https://hostpanda.net page instead of showing a secure version of their primary web pages. Why is the redirect occurring when I input the same address only including the https// now?

Thanks in advance.
Lance

Still need help with this one. https page redirects automatically to main https domain listed on the SAN SSL cert multi domain certificate.
Thanks in advance.

Hi hostpanda

Please could I ask what billing platform you use. Is it whmcs

I suspect it is been redirected back to hostpanda on https because of logic in whmcs

If not, did you activate the SSL and chains for the other siteworx accounts

If so, what is the https logic shown in their vhost file

Are there any htaccess setup on the siteworx domain

I myself do not believe a San cert for 4 domains would redirect, it has to be logic in some file causing it.

I hope that helps

Many thanks

John

Hi Hostpanda
Sorry, I did a quick check and I think you have not turned on SNI. Therefore, all requests for https will redirect to hostpanda
To turn on SNI (which allows multiple SSL on same IP address), login to nodeworx, server, settings, locate Apache, SNI and enable, save and then test. If it still fails, please flush your local pc cache, and also restart apache and iworx, ssh into server, service httpd restart and service iworx restart. Then test again
The only other thoughts I had, was if your using multi Word Press, perhaps its the logic in the config for word press, or you have set apache www to your site.
I think though, it is SNI not turned on which is the issue
Many thanks
John

Many thanks John.

The SNI was enabled upon checking. I also did restart apache and interworx via ssh, no change. I am getting this message when I restarted apache:

[[email protected] ~]# service httpd restart
Stopping httpd: [ OK ]
Flushing IPC Semaphores [ OK ]
Starting httpd: Starting httpd: [Tue Dec 06 18:22:05 2016] [warn] NameVirtualHost 127.0.0.1:443 has no VirtualHosts
[Tue Dec 06 18:22:05 2016] [warn] NameVirtualHost fe80::218:feff:fe8c:a562:443 has no VirtualHosts
[Tue Dec 06 18:22:05 2016] [warn] NameVirtualHost *:80 has no VirtualHosts

Interesting, when I type in https://garvers.us the URL remains in the browser, but the page displayed is the main page for hostpanda.net.
Also to answer your question about billing software I am using Blesta.

Thanks again for all of your help.
Lance

Hi Lance
Many thanks
I have not seen apache show *:80 has no virtualhosts, I would have expected this to show its IP address, unless you have removed it sorry, as 127.0.0.1 and fe80:: shows.
I do believe hostpanda is been displayed as it is the first alphabetical SSL domain (probably on bamboo.hostpanda), so as a test, can you create a siteworx account called 1sh.co.uk (this is my domain) and generate a self signed SSL cert, then try to reference garvers.us, which if I am correct, should display the new 1sh.co.uk SSL.
If you could update your post once tested and delete 1sh.co.uk
The reason why I do not think SNI is enabled, is because on testing, a server which is SNI enabled, would be displayed as such, and yours is not showing SNI only
Sorry, I should have asked, but are you on centos 7, if so, can you run cvspermsfix.pex, just in case
Also, a quick test to help track down what the issue is, is if you have a spare IP address, you could change hostpanda.net into a dedicated IP, and test gravers.us. The IP address could be private, as in say 192.168.2.2, as the test is to determine if SNI is working, and by changing hostpanda to dedicated IP, away from your live IP, it should not display hostpanda, but the first SSL site if SSL not working
I hope that makes sense
Many thanks
John