Stubborn IPv6 subpool + Nodeworx links broken by errors

I was disabling IPv6 and removing v6 addresses when I ran into a problem.

On the Nodeworx page under Server/IP Management/IPv6 Pools – there’s a subpool address that I’m unable to delete. This subpool’s delete link was always greyed out but I thought the subpool might go away if I deleted the pool itself. I was wrong. I’ve removed IPv6 setups before without this issue but I must have taken a wrong turn this time.

In Nodeworx if I go to Siteworx/Accounts and select the Manage IPs link or Edit link I get errors related to a file called IPv6PoolSW.php. Here’s the full error (debug mode on) when I click Manage IPs for this particular Siteworx account:

InterWorx Error Report
FILE: /usr/local/interworx/include/Input/IPv6PoolSW.php
LINE: 63
Call to a member function getRangeStartWithCIDR() on boolean

0 errorHandlerFatal (0)

And this error when I click the Edit link for the account:

A System Error Has Occurred
replyCode: 700
replyText: Call to a member function getRangeStartWithCIDR() on boolean in /usr/local/interworx/include/Input/IPv6PoolSW.php on line 63
0 errorHandlerFatal (0)

The stubborn subpool address was dedicated and bound to a domain using a SSL certificate which seems to be at the center of the problem.

For now IPv6 is enabled in the CentOS network files as well as iworx.ini.

Help or suggestions much appreciated.

Hi Sysnop
I hope your well
I’m sorry, I do not have any IPV6 cidr yet, I should I know sorry, and the datacentre said we could have a cidr…
There is the obvious, which you have stated, a service is using the IPV6 address, so have you tried to delete the SSL cert, but also, is there any other service using this or setup as a subdomains etc, which also may give a failure.
I do not suppose this V6 address is the local link V6, starting fe80:: (don’t shout, just thinking aloud)
Lastly, because the subpool delete key is greyed out, have you set the V6 into our NIC settings directly (ifcfg-eth0 etc…), which could account for the greyed key as IW is not controlling that V6
I would also open a support ticket and let IW have a look
I hope that helps and sorry if I’m wrong
Many thanks

Problem solved. Instead of stripping the SSL cert I just deleted the account and re-imported it.

On a side note, IPv6 was working tip-top in Interworx. The only missing component was IPv6 glue not available from my registrars.

Now, however, I’m getting an “inactive” license error. Not “invalid” but “inactive” and I’m out of options for fixing it. Is the license server missing a beat today by coincidence or did my messing with IPs and one Siteworx account cause the problem? Until it gets worked out I can’t save anything on the Settings page although I’ll probably get locked out first.

Hi sysnop

Glad you resolved it

I think you may have licensed using an IPv6 address, but you’ve stopped using IPv6

So I would login to Iw and change your license IP addrsss

If that’s not it, at the very least, you could check which IP address it is registered on

I hope that helps

Many thanks


Only a v4 address was used to register the license which is still the same IP.

My checklist:

  • IP and registration are ‘active’ at Licensecart
  • correct IP in iworx.ini
  • correct IPs in ifcfg-eth0 and eth0:iw1
  • correct IP in etc/hosts
  • name server in resolv.conf is
  • port 2443 is open for TCP, closed for UDP
  • system date/time are good
  • server talks to
  • receive ping replies from both &
  • both license server IPs are whitelisted in the firewall

The full error:

The last attempt to contact the license server failed. If communication isn’t restored, access to NodeWorx will be restricted. See this how-to for instructions to resolve the most common communication issues.

The license server reports that the key ‘INTERWORX_fjt8wn1lkjxx’ is inactive. Please contact InterWorx Support.

Hi sysnop

I’ve emailed Iw to ask if license servers are working normally

I guess so because our servers have not had issues and you can ping them directly from your server

Hopefully Iw may post or I’ll post when I receive a reply

Many thanks


Thanks John. These license issues always end up back to normal eventually.

Hi sysnop

Good news, there were a small issue on mike license server which has now been resolved (licensecart)

You can either run the licence.pex from ssh or wait for next cron license run

Kudos to IW Jenna for letting me know

Many thanks


These license errors are sometimes tricky and they always get resolved quickly enough, but I appreciate the extra effort from the IW team. The frustrating part was not knowing if my previous IP mistakes triggered the problem. Evidently not so I’m glad to know it was a coincidence.

Thanks once again John!

The license server reports that the key ‘INTERWORX_XXXXXXXXXXXX’ is inactive. Please contact InterWorx Support.

I’m so sick of this ****.

Hi sysnop

I hope your well

Hmmm I would open a support ticket to help resolve asap

Many thanks