suPHP issue w/ Wordpress in its own directory

While trying to install Wordpress in a directory of its own I get an internal server error if PHP is set to run as the Siteworx user (suPHP). If I switch PHP to Apache mode the install script runs. The install script runs either way as long as I’m installing into the web root instead of a directory. I haven’t tried any other PHP scripts except to say Drupal installed clean as silk a couple weeks ago in suPHP mode.

Correction: also get 500 internal server error with WP installed in web root.

Suggestions appreciated.

Hi sysnop

I hope you don’t mind, but have you tried the one click installers, simplescripts or softaculous to see if this causes the same issues.

Many thanks


Simplescripts gives the same result as installing WP manually.

Is it a subdomain? If so try this:

Add the following line to the .htaccess file:

RewriteBase /

No, not a subdomain, just a regular sub-directory as well as the web’s root directory. Disregard the thread title; I was mistaken about the problem being a directory only.

I’ve dabbled with a few .htaccess tips with no luck. Wordpress should be creating the appropriate .htaccess during install, I just don’t think it’s able.

Isolated vhosts aren’t that important for this server but would be nice. Aside from mod_suexec which is running, what other Apache modules could be missing that are necessary for suPHP to work?

My next experiment is to unpack the WP tarball as a shell user instead of uploading WP files as an FTP user. From what I’m reading (with no real clarity), 500 errors in suPHP scripts usually lead back to owner & permissions.

[SIZE=2]Hi Sysnop,

To get a little more background, was your system running mod_php, and then you recently switched it to suphp?

Definitely check to make sure permissions are correct. Under suPHP, everything should be owned by the SiteWorx account’s user and group.

Also, make sure both of these are owned by the SiteWorx account’s user and group:


suPHP also enforces the following:

  • [SIZE=2]directory php files cannot be chmod 777 — should be 755[/SIZE]
  • [SIZE=2]php files should be 644 or 640[/SIZE]
  • [SIZE=2]group can’t be world writable[/SIZE]
  • [SIZE=2]other can’t be world writable[/SIZE]
[SIZE=2]Lastly, definitely check /var/log/httpd/suphp.log for errors related to the site[/SIZE]

That’s the first riddle. I know I didn’t switch recently so I must have done it during or shortly after installing Interworx.

I’m getting my crash course in suphp owner/permissions. In fact, when I checked a couple WP installations that couldn’t start as described, all I found as I recall, was 755 for directores & 644 for php files, all with matching owner/user. Ditto for the user’s html directory. For now I’m running in mod_php mode. Hope it doesn’t hurt to toggle this switch too many times.