Turing off catchall results in mailbox failure

Hi all,

a custopmer wanted a catchall adress set up but now realized he gets way too much spam that way :wink:

So I switched the bounce message setting back to “On - Reject”. But mails to any recipient are still received, only not delivered into the mailbox. From smtp-current log:

2016-12-05 10:46:49.601763500 CHKUSER accepted any rcpt: from <me@mydomain.com::> remote <mydomain.com:unknown:123.456.789.123> rcpt <info@domain.de> : accepted any recipient for this domain

Digging a little further I see this in the send-current log:

2016-12-05 10:53:30.729221500 delivery 206: deferral: Unable_to_switch_to_/home/vpopmail/domains/domain.de:_file_does_not_exist._(#4.3.0)
2016-12-05 10:53:30.728170500 status: local 1/10 remote 0/2552016-12-05 10:53:30.728164500 starting delivery 206: msg 8260552 to local domain.de-info@domain.de

When I try to delete the mailbox in order to set it up from scratch, I get

 ? Error: Unable to chdir to vpopmail/domains directory

And in the iworx log I see all kinds of errrors like

disk usage cmd failed on /home/vpopmail/domains/domain.de/info : vpopmail.php


2016-12-05 10:52:09.69516 [isji5l-jjyx-med1-CLI] [INFO]  : Can not set vacation for non-existent e-mail box : vpopmail.php
2016-12-05 10:52:09.65052 [isji5l-jjyx-med1-CLI] [NOTICE]: vpopmail.php --set-vacation-message=/tmp/VACAn9jgXF --user=info --domain=domain.de : vpopmail.php

There is no autoresponder set up, so I have no idea what is happening at the last error. In any case, something is severely amiss with that mailaccount and since I can’t delete it, I am not sure on how to proceed.

Any pointers?

Hi Michael
I hope your well
I have tried this, and it works fine for me
I would probably restart qmail (service smtp restart), and/or run cvspermsfix.pex, as I think your on Centos7
I hope that helps
Many thanks
Cathall reject
2016-12-05 10:29:03.117741500 CHKUSER rejected rcpt: from <john@domain.url::> remote <mail.externalsendingserver.url:unknown:5.153.> rcpt <test@siteworxdomain.url> : not existing recipient
Catchall forwards to recipient
2016-12-05 10:31:44.072362500 CHKUSER accepted any rcpt: from <john@domain.url::> remote <mail.externalsendingserver.url:unknown:5.153.> rcpt <test@siteworxdomain.url> : accepted any recipient for this domain
catchall reject
2016-12-05 10:36:19.122016500 CHKUSER rejected rcpt: from <john@domain.url::> remote <mail.externalsendingserver.url:unknown:5.153.> rcpt <test@siteworxdomain.url> : not existing recipient

Hi Michael
I tried this using a test Centos 7 server and it works as expected.
DId the qmail or cvs fix it
Many thanks
CentOS Linux release 7.2.1511 (Core)
IW 5.1.38-1257
Cathcall forwards to recipient
2016-12-05 11:01:33.713518500 starting delivery 8: msg 135210906 to local 403test.url-postmaster@403test.url2016-12-05 11:01:33.712151500 info msg 135210906: bytes 625 from <ma@myteston.url> qp 15030 uid 108
Catchall Reject
2016-12-05 11:05:29.535679500 delivery 11: failure: Sorry,no_mailbox_here_by_that_name.(#5.1.1)/2016-12-05 11:05:29.504008500 status: local 1/10 remote 0/255 2016-12-05 11:05:29.504007500 starting delivery 11: msg 134497266 to local 403test.url-test@403test.url2016-12-05 11:05:29.502661500 info msg 134497266: bytes 528 from <ma@myteston.url> qp 15898 uid 240

Hi John,

I did try to restart the service (and even the whole server) but nothing helped so far :frowning:

I guess the catchall setting not being heeded is just a symptom and the underlying problem has more to do with the symlink in /var/vpopmail/domains missing.
Not sure why that is/happened, will try to restore it and see what happens.

Restoring the symlink helped. So the problem really was “my computer ate the symlink” :wink:

Hi Michael

Dam, don’t you just hate that when it happens :frowning:

Do you mind me asking, if you repeat the add/test/stop/test, does it remove the symlink or was it something different which removed the symlink - thinking if an Iw update removed the symlink

Many thanks


Hi John,

yes, exactly my reaction, I hate it when things are solved pretty easily but the real reason is still in the dark. I mostly assume that it is a Pebcac problem then :wink:

For the sake of completeness I tested it as you said but the process didn’t touch the symlink nor did the problem reoccur.