Update not arriving


Where is version 5.1.46 build 1286? :slight_smile: According to the release notes it has been released 5 days ago. Is it revoked? (We are on release channel.)


Hi dss

Many thanks

I have checked, and I cannot see where it shows as revoked sorry.

We have 5.1.46-1286 running

Please could I ask if your not seeing the RC update as available to you

If so, you may want to try yum clean iworx I think it is, and rerun Iw check for updates, or sorry, please do not shout, but is your server set to RC updates and not stable etc… just a thought

Many thanks


I have checked our servers, all of them on the Release channel, ran yum clean all and tried to check the updates again.
I looked into the repositories here and it looks like the last version on the release channel is 5.1.41-1262 which we are currently using.

Hi Dss
Many thanks, and sorry, it might have been a simple explanation, I have made the mistake myself sorry.
I think you are looking at the wrong repos, see pic, should the repo not be release-candidate
Also, as I believe you may already be running 5.1.46-1286, please could you check your full version been used from nodeworx, remote support (see pic).
I hope that helps a little but sorry if I am wrong
Many thanks

Current version on the server:

Update channel:

This is the current state in the RPM folder of the release channel:

You can see the last update was on 22th February but the last file uploaded on 04th January so it looks like something has been deleted.

And this is the changelog containing the version 5.1.46 and it was released as Release on 22th February according to the entry.

So that’s why I think it has been revoked. :slight_smile:

Hi dss

Many thanks

I do not believe it has been revoked, or downgraded to earlier version from Iw as all our servers are showing correct

There is a yum update for iworx, which you should be able to manually run from ssh, which I think from memory you add the release-candidate as append similar to yum update iworx --release-candidate, but I’m not at my pc so doing this from memory.

If that does not work, you could try setting update in nodeworx to stable, save and change it back to release candidate, save - check for updates

If this does not work, I would open a support ticket with Iw and let Iw have a look to see what’s gone wrong for you

One final thought, are you clustered, because if node server, I thought it received updates from cluster manager

Many thanks


Hi Dss
Sorry, actually your still looking at release and not release-candidate.
Please see pic for release-candidate showing latest version
I hope that helps a little but sorry if I am wrong
Many thanks

We are not clustered. I tried to update via yum and changing the release channels but did not work.
I’m going to send a ticket to IW, thank you for your help!

Yes, I am looking at release, because according to the release notes this version has been released as Release on 22th February.

Release–Version 5.1.46 build 1286 (2017-02-22)
Released as Beta on 2017-02-07
Released as Release Candidate on 2017-02-14 - This is your last image with the same date.
Released as Release on 2017-02-22 - This is I am looking for :slight_smile:

Hi dss

Ahh the penny drops as we say in the U.K. Sorry

Now I understand why you refer to release - apologises for not understanding

It may just be a case that it has not been moved to release section, so I’ll email Jenna and quote this thread so you have credit

Please could you update your thread when resolved

Many thanks


Thank you for everything, you helped as always!
I think I ought to be more accurate and more understandable :slight_smile:
I will update the thread when something occurs!

Thank you again!


I apologize for the confusion. 5.1.46-1286 was released on the 22nd, however, it was also pulled later in the day due to bugs solely related to php-fpm. We initially decided to hotfix the issue, but then decided it was best to pull it completely. I’ve updated the changelog to reflect this.

Again, the bugs were only related to php-fpm, so those customers who have 5.1.46-1286 who are not or will not use that feature don’t have to worry about anything. We recommend that any customers who are interested in php-fpm switch to the Release Candidate channel for the time being. There should be an update being promoted to that channel this week.

So, depending on time zones and cron schedules, some people received that release and some people did not. So, DSS, everything on your end is probably working correctly in regards to updating, your daily cron just probably ran after the release was pulled, so the update never occurred because there was nothing there for it to update. :slight_smile:


Thanks Jenna, everything is clear now!

Hi Again! Just a correction–the update today ended up being released to the Beta channel instead of being released straight to Release Candidate like I originally said. Thanks! :slight_smile:

Hi Jenna

Excellent news, many thanks, you guys rock

It should not be too long before been pushed to RC if beta passes ok

Once again, many thanks