Users failing to login


My Siteworx users are failing to login …
I also tried to login as well and even with the correct set password on https://hostname:2443/siteworx it gives the following error

There was a problem validating the form. Please see details below.                    
                            Authentication Error                         

Any ideas how i can quickly solve this ?


I just checked the lohs and tried again this is what i get

.56..163 - - [28/Apr/2015:17:26:43 -0400] “POST /xhr.php HTTP/1.1” 200 676 “https://hostnamehere:2443/nodeworx/logs” “Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.90 Safari/537.36”::1 - - [28/Apr/2015:17:26:49 -0400] “OPTIONS * HTTP/1.0” 200 - “-” “Apache (internal dummy connection)”
.56..163 - - [28/Apr/2015:17:27:17 -0400] “POST /siteworx/index?action=login HTTP/1.1” 200 1882 “https://hostnamehere:2443/siteworx/index?action=login” “Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0”

Hi nuffsaid

Please could I ask if the MySQL service is running

I assume it is as your posting from nodeworx

Does it do the same if you reverse your mod security change

If it is extremely important, I would advice open a support ticket with IW, but please ensure you enable remote support from nodeworx, remote support and when opening a ticket, please ensure you state remote support has been enabled.

Many thanks



Sorry, have you also restarted iWorx or you server

Many thanks


I have removed mod_security and mod_evasive then restarted httpd still can’t login …

Let me open a support ticket…

Turns out that i was the one who was making login mistakes …

The domain section in the login form, it pre-filled the hostname so i automatically assumed thats the way it is instead of changing it to the account’s hostname …

Is they something i can change to make sure the hostname stays blank without pre-filling it ? that will save quite a number of tickets on my side …

Hi nuffsaid

Many thanks for posting what your issue was.

We normally auto send an email to new accounts with their login details, which is always their domain name/siteworx ie mydomain.irl/siteworx, and this inserts the correct domain (a lot of our clients complained they did not want to type their domain) but you can change the way it works as follows

Ssh into server
vi /etc/httpd/conf.d/iworx.conf
Locate rewriterule for siteworx, and delete the ?domain=%{HTTP_HOST}

Save and restart apache

Many thanks