Validation error when creating SiteWorx Account due to invalid property (requires_password_change)

Hello everyone,

I haven’t been able to find any online resource with any information about my issue, so hopefully someone on the forum will be able to help.

My freshly installed InterWorx v6.9.0 server running on CentOS 7 has an issue creating new SiteWorx accounts. The NodeWorx interface reports a validation error despite providing all required information. Looking through the InterWorx log file (/home/interworx/var/log/iworx.log), the following error message stands out:

[ERR] : Tried to set an invalid property (requires_password_change). Valid properties are user_id, global_uid, nickname, email, password, type, status, language, theme, package_id, menu_style, ssh_enabled, ssh_username, ssh_public_key : /xhr.php

The same issue occurs even when attempting to create the SiteWorx account through the nodeworx utility in interactive or non-interactive mode on the command line.

Does anyone have any idea what’s going on here?

Thank you for the help!

Hi Deiony

Welcome to IW forums

I have just tested this on one of our servers (IW 6.9 and centos 7) and it works lovely. Tested in full by creating a siteworx account, setting to change password and then logging into teh siteworx account and it took me to change password, changed password and all was well

I would think it is your password that maybe the issue

Could you try without any symbols, so just upper/lower case and numbers as a test

There are a few symbols which if used, causes an issue such as $ I think and a few more, as they are interpreted differently as command symbols I believe, but coudl be entirely wrong sorry

If it still gives same error, I would open a support ticket with IW and let them have a look to see what going wrong.

Many thanks



It is really odd that that error is coming from a freshly installed server, as I’ve only seen it occur on existing servers.

What seem to be happening is that, in 6.7.4, we added a setting to have the option to require that new accounts have to change their password upon first login. In the servers where I’ve seen this error, either the upgrade step was not run, or it was run and was marked completed, but for some reason the field was still not added to the database. It’s popped up on maybe five or six servers in the last few years, but this is the first I’ve heard of it being an entirely new, fresh install of a version past 6.7.4.

Try running the following:

~iworx/bin/iworx-upgrade.pex --run --step 6690 --force --verbose

That will run the step if it was not completed (which I don’t see how that could be the case since a new install should have it already set up), and force it to re-run if it was marked as complete, but did not add the field.

That should allow you to create a SiteWorx account.

Since this is a new server, and, like I said, that is kind of weird, if you want, also submit a ticket to with your IP, port, and remote assistance enabled and I can take a look around and check for any other weird missed steps that might have occurred.

Friendly Neighborhood InterWorx Support Manager

1 Like

Hello d2d4j and Jenna,

Thank you for the suggestions.

I have consulted with my support engineer who set up the InterWorx server, and turns out that Jenna was right about the server not being a fresh InterWorx v6.9.0 installation. The InterWorx server originally started out at v6.4.1 and was upgraded.

After running the provided command, the issue with the validation error when creating new SiteWorx accounts was resolved.

Once again, thanks for all the help!

Great! Glad that worked! :slight_smile:

One thing you might want to also do, just as a precaution, is run our upgrade catchup script. It will re-run any failed or incomplete steps in any past upgrades (it would not have worked for the above, if the step had been marked complete). It should just tell you that everything has already been run and is up to date, but could be worth it just to check.

~iworx/bin/iworx-upgrade.pex --catchup --verbose

Let me know if there is anything else I can help with! :slight_smile: