Virtuozzo/OpenVZ VPS settings for Interworx panel


As it’s stated from title, I have virtuozzo based VPS. I have also ticket opened, but I want that also others, who comes to Interworx and maybe have same problem, see solution for it.

So, where is the problem, let me start from beginning:

  1. I thought that I don’t have second-level quotas on. Even my provider told me it can not be done. They pointed me to complete specification of my VPS, where I saw “QUOTAUGIDLIMIT 1000”
    All fine, second-level quota is enabled for 1000 users - more than enough for my VPS.
  2. I need to point usrquota and grpquota in /etc/fstab, but how?
    My /etc/fstab is like this:
cat /etc/fstab:
none /dev/pts devpts rw 0 0
df -h:
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/ploop19895p1 103079200 1749728 97030692 2% /
none 1048576 4 1048572 1% /dev

Now, I would like to add usrquota and grpqouta to /.

I saw a lot of guides on how to do, but nothing is good enough to make it works. I tried few different options and also when it comes to mount -o remount / I get message permission denied.

I hope we together figure out (with much of your help community) and set this vps to run interworx panel. I must say that there are no errors durring installation, I can login to panel and everything, but thats all I can do. No creation or import accounts because od that. Also in healt system it says I don’t have user and group quota on /.

Hi dennisdee

Welcome to the forum

Where did you open support ticket and is it still ongoing

You may want to review the following, if your sure second level quotas are turned on.

Also, please search the forum for rebuilding quotas, which may also resolve your issue

I hope that helps and sorry if I have not understood your post fully

Many thanks



Here’s the post for rebuilding quotas. I suspect it’s tied in with your home folder quotas.

Many thanks


Hi d2d4j,

So I did try this from rebuilding quotas and here are results:

# mount |quotacheck -cugvmf -F vfsv0 /quotacheck: Mountpoint (or device) / not found or has no quota enabled.
quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.

I also tried mount |quotacheck -cugvmf -F vfsv0 /dev/ploop19895p1 and results are:

# mount |quotacheck -cugvmf -F vfsv0 /dev/ploop19895p1
quotacheck: Cannot find mountpoint for device /dev/ploop19895p1
quotacheck: No correct mountpoint specified.
quotacheck: Cannot initialize mountpoint scan.

Nathan pointed me to So my /etc/fstab looks like:

none    /dev/pts        devpts  rw      0       0
/dev/ploop19895p1       /       ext4    defaults,usrquota,grpquota      1       1

and I stuck at

quotacheck -cug /
# quotacheck -cug /
quotacheck: Mountpoint (or device) / not found or has no quota enabled.
quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.

Hi dennisdee

I think your mount is wrong.

If your not sure how to mount correctly, I would restart your vps or as root, I’d try mount -o remount /

Then you need to rebuild quotas quotacheck -cugvmf -F vfsv0 /

Many thanks


Hi d2d4j,

all this was done with root access. Thats why I reboot my vps (I forgot to mention that), but everything same. Nathan helps me at the moment to solve this, so lets keep fingers crossed.
Thats why I said before, this is not standard /etc/fstab problem, as far as I noticed. I will report later, what was wrong or what I made worng, who knows…

Is it possible that quotaugidlimit is set to 1000, but second level quota is disabled?

Hi dennisdee

Sorry, I thought your last post said Nathan was looking into your issue. IW guys rock.

Appreciate an update after it’s been resolved.

I always thought quotaugidlimit was the second level quotas, although I suppose it may not have been fully applied. If so, you can always run the command again to be sure.

Also, given what you have posted, if it is not second level quotas issue, what do you have shown in iWorx.ini for partition=

Many thanks


He did, but he said my VPS is ultra limited with commands. Now, he tried to use command vzctl (as far as I understand, this command can use only container admins right?), but command doesn’t work. So basically I am where I was. I wrote ticket to my provider now to check if quotaugidlimit is enabled for real. It is much frustrated situation at the moment :/.

I forgot to mention, PARTITON=/

With all of my tickets I prepare them to give me in ticket directly with one of system engineers, so now I am waiting on his answer. I hope someone who rented Openvz/virtuozzo vps answer here and give me/us some information about setting up quotas as person who have access only to VPS and not to container.

Well what I figuret till now:

When I run usrquota and grpquota on server, where Plesk is preinstalled, quotas works. After that I do fresh install of CentOS and do same things to run quotas, but nothing appears.

So, editing fstab with adding

/dev/ploop19895p1 / ext4 defaults,usrquota,grpquota 1 1

after that reboot and run commands

quotaon -uga
quotacheck -cuga

repquota -uga

This very same commands works, when there is PLESK on server, but not on fresh install. I do have installed quota.

Hi dennisdee

I’m sure if your ticket is with IW, it will get resolved.

It is strange though, as it would appear your second level quotas are on.

I’d appreciate updates as it progresses but please be clear where you opened support ticket with.

Many thanks


I will update with final solution what I did. Until now I tried to manage this problem with Nathan (Interworx support center). As soon as I have some updates, I will report here. Also if someone other have some idea, I will be more than happy to try something else.

And thank you John for your time with trying to help me.


Hi dennisdee

Sorry, it’s very late here, but a quick thought which I’m sure has been checked, but it’s not a simple case of permission on quota files stopping it is it.

I’m thinking if plesk can use quota files, perhaps it assigned to a particular user or group, which iWorx may not be assigned.

As I said, it’s very late and I’m very tired, so apologies in advance if I’m wrong

Many thanks


I opened another ticket with my hosting provider, so I will see what they will answer me. I made few more tests now, as it’s late here also (1:41 am atm).

  1. Snapshot was created for backup of my websites on Plesk. Here user and group quotas works.
  2. I tried as I told you before, clean install of CentOS and it does not work.
  3. Also tried to install centos with plesk, same results as on point 2, does not work.

I am thinking, second level quota is restarted to its original after reinstalling OS? Anyway, it is late and we all need to sleep a bit :).

Have a good night,

Did we ever get an answer on this? My exoerience would lead me to believe that they ARE turned off after an OS reload.

Hi transwarptim

I suspect your correct but unfortunately I do not use virtuoso, however, hopefully another user may be able to confirm

Many thanks


If the quota’s are playing up you could try the Linode fix for Xen (might work)

or you could try: