Webalizer problem...

I’m using Interworx site manager on RH 9.0 platform and I would like to use Webalizer statistics that I use before. When I accessed it’s link from site manager, main Webalizer display appears but without graph image and with only total datas foronth. mWhen I click on “May” link, blank page appears with this message:“Not Found The requested URL /siteworx/usage_200405.php was not found on this server”

I found that system create and store full webalizer statistics report in a:
Obviously Nodeworx looks in a wrong place - how can I fix this ?

Thank you !

Hi Andrej,

This can happen if the server is updated before the InterWorx license has been activated. You can fix this easily by logging into your server as root, and running:

rpm -Uvh --force http://updates.interworx.info/redhat/iworx/9/contrib/webalizer-2.01_10-1.iworx.i386.rpm

Then the next time stats are calculated the images will show up and the links will work correctly. If you don’t want to wait you can run:



Thank you !

What about RHEL 5.2?

I tried rpm -Uvh --force http://updates.interworx.info/redhat/iworx/9/contrib/webalizer-2.01_10-1.iworx.i386.rpm and got:

Retrieving http://updates.interworx.info/redhat/iworx/9/contrib/webalizer-2.01_10-1.iworx.i386.rpm
error: Failed dependencies:
libdb-4.0.so is needed by webalizer-2.01_10-1.iworx.i386
libgd.so.1.8 is needed by webalizer-2.01_10-1.iworx.i386

RHEL compatible rpms are located here:


Thanks, that worked. When I ran the cron, I got:

[root@planet ~]# php /home/interworx/cron/stats.php
Site error: the file <b>/usr/local/interworx/cron/stats.php</b> requires the ionCube PHP Loader ioncube_loader_lin_5.1.so to be installed by the site administrator.[root@planet ~]#

The right way to run it is like this: